net/libiscsi - The NetBSD Packages Collection

iscsi client library and utilities

Libiscsi is a client-side library to implement the iSCSI protocol that can
be used to access the resources of an iSCSI target.

The library is fully asynchronous with regards to iSCSI commands and SCSI
tasks, but a synchronous layer is also provided for ease of use for simpler
applications.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/gmake devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 8.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 8.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 8.0i386libiscsi-1.19.0.tgz
NetBSD 8.0i386libiscsi-1.19.0.tgz
NetBSD 8.0i386libiscsi-1.19.0.tgz
NetBSD 8.0powerpclibiscsi-1.19.0.tgz
NetBSD 8.0powerpclibiscsi-1.19.0.tgz
NetBSD 8.0powerpclibiscsi-1.19.0.tgz
NetBSD 8.0powerpclibiscsi-1.19.0.tgz
NetBSD 8.0x86_64libiscsi-1.19.0.tgz
NetBSD 8.0x86_64libiscsi-1.19.0.tgz
NetBSD 8.0x86_64libiscsi-1.19.0.tgz
NetBSD 9.0aarch64libiscsi-1.19.0.tgz
NetBSD 9.0aarch64libiscsi-1.19.0.tgz
NetBSD 9.0aarch64libiscsi-1.19.0.tgz
NetBSD 9.0alphalibiscsi-1.19.0.tgz
NetBSD 9.0alphalibiscsi-1.19.0.tgz
NetBSD 9.0alphalibiscsi-1.19.0.tgz
NetBSD 9.0earmlibiscsi-1.19.0.tgz
NetBSD 9.0earmlibiscsi-1.19.0.tgz
NetBSD 9.0earmlibiscsi-1.19.0.tgz
NetBSD 9.0earmv6hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv6hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv6hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv6hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 9.0earmv7hflibiscsi-1.19.0.tgz
NetBSD 9.0i386libiscsi-1.19.0.tgz
NetBSD 9.0i386libiscsi-1.19.0.tgz
NetBSD 9.0i386libiscsi-1.19.0.tgz
NetBSD 9.0m68klibiscsi-1.19.0.tgz
NetBSD 9.0m68klibiscsi-1.19.0.tgz
NetBSD 9.0mips64eblibiscsi-1.19.0.tgz
NetBSD 9.0mips64eblibiscsi-1.19.0.tgz
NetBSD 9.0mips64eblibiscsi-1.19.0.tgz
NetBSD 9.0mipsellibiscsi-1.19.0.tgz
NetBSD 9.0mipsellibiscsi-1.19.0.tgz
NetBSD 9.0powerpclibiscsi-1.19.0.tgz
NetBSD 9.0powerpclibiscsi-1.19.0.tgz
NetBSD 9.0powerpclibiscsi-1.19.0.tgz
NetBSD 9.0powerpclibiscsi-1.19.0.tgz
NetBSD 9.0sh3ellibiscsi-1.19.0.tgz
NetBSD 9.0sh3ellibiscsi-1.19.0.tgz
NetBSD 9.0sparc64libiscsi-1.19.0.tgz
NetBSD 9.0sparc64libiscsi-1.19.0.tgz
NetBSD 9.0sparc64libiscsi-1.19.0.tgz
NetBSD 9.0sparc64libiscsi-1.19.0.tgz
NetBSD 9.0sparclibiscsi-1.19.0.tgz
NetBSD 9.0sparclibiscsi-1.19.0.tgz
NetBSD 9.0sparclibiscsi-1.19.0.tgz
NetBSD 9.0vaxlibiscsi-1.19.0.tgz
NetBSD 9.0vaxlibiscsi-1.19.0.tgz
NetBSD 9.0x86_64libiscsi-1.19.0.tgz
NetBSD 9.0x86_64libiscsi-1.19.0.tgz
NetBSD 9.0x86_64libiscsi-1.19.0.tgz
NetBSD 9.0x86_64libiscsi-1.19.0.tgz
NetBSD 9.0x86_64libiscsi-1.19.0.tgz
NetBSD 9.0x86_64libiscsi-1.19.0.tgz
NetBSD 9.0x86_64libiscsi-1.19.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.