multimedia/mpeg_encode - The NetBSD Packages Collection

The Parallel Berkeley MPEG Encoder

The primary focus of MPEG encoding algorithms is 1) To create fast
and efficient motion vector search techniques and 2) To find "good"
encoding parameters that provide a balance of encoding speed,
compression and quality.

The Berkeley encoder accelerates the process by parallelizing in
the temporal direction. The overall organization of the encoder is
shown in Figure 2. The Master server is the overall coordinator.
It allocates groups of frames to the Slave servers for encoding.
The sharing of the files is achieved best, if the directories
containing the video files are NFS mounted and accessible uniformly
to all processors (alternatively they can be sent out though sockets
by the Master). The various activities are managed by inter process
communication through sockets.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

graphics/jpeg graphics/jpeg

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 8.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 8.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 8.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 8.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 8.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 8.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 8.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 8.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 8.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 8.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 8.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 8.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 8.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 8.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 8.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 8.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0aarch64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0aarch64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0aarch64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0aarch64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0alphampeg_encode-1.5bnb6.tgz
NetBSD 9.0alphampeg_encode-1.5bnb6.tgz
NetBSD 9.0earmmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv6hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv6hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv6hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv6hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv6hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0earmv7hfmpeg_encode-1.5bnb6.tgz
NetBSD 9.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 9.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 9.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 9.0i386mpeg_encode-1.5bnb6.tgz
NetBSD 9.0mips64ebmpeg_encode-1.5bnb6.tgz
NetBSD 9.0mips64ebmpeg_encode-1.5bnb6.tgz
NetBSD 9.0mips64ebmpeg_encode-1.5bnb6.tgz
NetBSD 9.0mips64ebmpeg_encode-1.5bnb6.tgz
NetBSD 9.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0powerpcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0sh3elmpeg_encode-1.5bnb6.tgz
NetBSD 9.0sparc64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0sparc64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0sparcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0sparcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0sparcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0sparcmpeg_encode-1.5bnb6.tgz
NetBSD 9.0vaxmpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz
NetBSD 9.0x86_64mpeg_encode-1.5bnb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.