multimedia/intel-vaapi-driver - The NetBSD Packages Collection

VA-API user mode driver for Intel GEN Graphics family

VA-API (Video Acceleration API) user mode driver for Intel GEN
Graphics family.

VA-API is an open-source library and API specification, which
provides access to graphics hardware acceleration capabilities for
video processing. It consists of a main library and driver-specific
acceleration backends for each supported hardware vendor.

The current video driver backend provides a bridge to the GEN GPUs
through the packaging of buffers and commands to be sent to the
i915 driver for exercising both hardware and shader functionality
for video decode, encode, and processing.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/gmake devel/pkgconf

Runtime dependencies

multimedia/libva x11/libdrm

Binary packages

OSArchitectureVersion
NetBSD 8.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 8.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 8.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 8.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 8.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 8.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 8.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 8.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0i386intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz
NetBSD 9.0x86_64intel-vaapi-driver-2.4.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.