inputmethod/ibus-chewing - The NetBSD Packages Collection

Chewing engine for IBus input platform

IBus-chewing is an IBus front-end of Chewing, an intelligent Chinese input
method for Zhuyin (BoPoMoFo) users.
It supports various Zhuyin keyboard layout, such as standard (DaChen),
IBM, Gin-Yeah, Eten, Eten 26, Hsu, Dvorak, Dvorak-Hsu, and DaChen26.

Chewing also support toned Hanyu pinyin input.

Build dependencies

devel/gob2 pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/pkgconf

Runtime dependencies

devel/glib2 inputmethod/ibus inputmethod/libchewing x11/gtk2 x11/libXtst devel/glib2 inputmethod/ibus inputmethod/libchewing x11/gtk2

Available binary packages

aarch64:ibus-chewing-1.4.12nb24.tgz(NetBSD 9.0)
aarch64:ibus-chewing-1.4.12nb25.tgz(NetBSD 9.0)
aarch64:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)
earmv7hf:ibus-chewing-1.4.12nb26.tgz(NetBSD 8.0)
earmv7hf:ibus-chewing-1.4.12nb22.tgz(NetBSD 8.0)
earmv7hf:ibus-chewing-1.4.12nb24.tgz(NetBSD 8.0)
i386:ibus-chewing-1.4.12nb24.tgz(NetBSD 8.0)
i386:ibus-chewing-1.4.12nb25.tgz(NetBSD 8.0)
i386:ibus-chewing-1.4.12nb26.tgz(NetBSD 8.0)
i386:ibus-chewing-1.4.12nb24.tgz(NetBSD 9.0)
i386:ibus-chewing-1.4.12nb25.tgz(NetBSD 9.0)
i386:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)
sparc64:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)
sparc64:ibus-chewing-1.4.12nb25.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb25.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb25.tgz(NetBSD 8.0)
x86_64:ibus-chewing-1.4.12nb24.tgz(NetBSD 8.0)
x86_64:ibus-chewing-1.4.12nb26.tgz(NetBSD 8.0)
x86_64:ibus-chewing-1.4.12nb24.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb25.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)
x86_64:ibus-chewing-1.4.12nb26.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]