graphics/vcg - The NetBSD Packages Collection

Visualization Tool for compiler graphs

The VCG tool reads a textual and readable specification of a
graph and visualizes  the graph.   If  not  all positions of
nodes are fixed,  the tool  layouts the graph using  several
heuristics as reducing  the number of crossings,  minimizing
the  size of  edges,  centering of nodes.  The specification
language of  the  VCG  tool is nearly compatible to GRL, the
language of the edge tool, but contains many extensions. The
VCG tool  allows folding of dynamically or statically speci-
fied  regions  of the  graph.  It uses  colors and  runs  on
X11. (An older version runs on Sunview).

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/imake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfvcg-1.30nb1.tgz
NetBSD 8.0earmv7hfvcg-1.30nb1.tgz
NetBSD 8.0earmv7hfvcg-1.30nb1.tgz
NetBSD 8.0i386vcg-1.30nb1.tgz
NetBSD 8.0i386vcg-1.30nb1.tgz
NetBSD 8.0powerpcvcg-1.30nb1.tgz
NetBSD 8.0powerpcvcg-1.30nb1.tgz
NetBSD 8.0powerpcvcg-1.30nb1.tgz
NetBSD 8.0powerpcvcg-1.30nb1.tgz
NetBSD 8.0x86_64vcg-1.30nb1.tgz
NetBSD 8.0x86_64vcg-1.30nb1.tgz
NetBSD 9.0aarch64vcg-1.30nb1.tgz
NetBSD 9.0aarch64vcg-1.30nb1.tgz
NetBSD 9.0aarch64vcg-1.30nb1.tgz
NetBSD 9.0alphavcg-1.30nb1.tgz
NetBSD 9.0alphavcg-1.30nb1.tgz
NetBSD 9.0alphavcg-1.30nb1.tgz
NetBSD 9.0earmv6hfvcg-1.30nb1.tgz
NetBSD 9.0earmv6hfvcg-1.30nb1.tgz
NetBSD 9.0earmv6hfvcg-1.30nb1.tgz
NetBSD 9.0earmv7hfvcg-1.30nb1.tgz
NetBSD 9.0earmv7hfvcg-1.30nb1.tgz
NetBSD 9.0earmv7hfvcg-1.30nb1.tgz
NetBSD 9.0earmv7hfvcg-1.30nb1.tgz
NetBSD 9.0i386vcg-1.30nb1.tgz
NetBSD 9.0i386vcg-1.30nb1.tgz
NetBSD 9.0i386vcg-1.30nb1.tgz
NetBSD 9.0mips64ebvcg-1.30nb1.tgz
NetBSD 9.0mips64ebvcg-1.30nb1.tgz
NetBSD 9.0mips64ebvcg-1.30nb1.tgz
NetBSD 9.0mips64ebvcg-1.30nb1.tgz
NetBSD 9.0mips64ebvcg-1.30nb1.tgz
NetBSD 9.0powerpcvcg-1.30nb1.tgz
NetBSD 9.0powerpcvcg-1.30nb1.tgz
NetBSD 9.0powerpcvcg-1.30nb1.tgz
NetBSD 9.0powerpcvcg-1.30nb1.tgz
NetBSD 9.0sparc64vcg-1.30nb1.tgz
NetBSD 9.0sparc64vcg-1.30nb1.tgz
NetBSD 9.0sparc64vcg-1.30nb1.tgz
NetBSD 9.0sparcvcg-1.30nb1.tgz
NetBSD 9.0sparcvcg-1.30nb1.tgz
NetBSD 9.0sparcvcg-1.30nb1.tgz
NetBSD 9.0sparcvcg-1.30nb1.tgz
NetBSD 9.0x86_64vcg-1.30nb1.tgz
NetBSD 9.0x86_64vcg-1.30nb1.tgz
NetBSD 9.0x86_64vcg-1.30nb1.tgz
NetBSD 9.0x86_64vcg-1.30nb1.tgz
NetBSD 9.0x86_64vcg-1.30nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.