graphics/py-piddle - The NetBSD Packages Collection

Python Plug In Drawing, Does Little Else

Plug In Drawing, Does Little Else. A cross-platform drawing library for
Python.

PIDDLE is a Python module for creating two-dimensional graphics in a manner
that is both cross-platform and cross-media; that is, it can support screen
graphics (e.g. QuickDraw, Windows, Tk) as well as file output (PostScript,
PDF, GIF, etc.). It makes use of the native 2D drawing calls of each backend,
for maximum efficiency and quality. It works by defining a base class
(piddle.Canvas) with methods for all supported drawing primitives. A
particular drawing context is provided in the form of a derived class. PIDDLE
applications will be able to automatically select an appropriate backend for
the user's environment.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-piddle-1.0.15nb3.tgz
NetBSD 8.0earmv7hfpy27-piddle-1.0.15nb3.tgz
NetBSD 8.0earmv7hfpy27-piddle-1.0.15nb3.tgz
NetBSD 8.0i386py27-piddle-1.0.15nb3.tgz
NetBSD 8.0i386py27-piddle-1.0.15nb3.tgz
NetBSD 8.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 8.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 8.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 8.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 8.0x86_64py27-piddle-1.0.15nb3.tgz
NetBSD 8.0x86_64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0aarch64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0aarch64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0aarch64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0alphapy27-piddle-1.0.15nb3.tgz
NetBSD 9.0alphapy27-piddle-1.0.15nb3.tgz
NetBSD 9.0alphapy27-piddle-1.0.15nb3.tgz
NetBSD 9.0earmv6hfpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0earmv6hfpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0earmv6hfpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0earmv7hfpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0earmv7hfpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0earmv7hfpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0earmv7hfpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0i386py27-piddle-1.0.15nb3.tgz
NetBSD 9.0i386py27-piddle-1.0.15nb3.tgz
NetBSD 9.0i386py27-piddle-1.0.15nb3.tgz
NetBSD 9.0mips64ebpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0mips64ebpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0mips64ebpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0mips64ebpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0mips64ebpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0powerpcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0sparc64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0sparc64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0sparc64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0sparcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0sparcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0sparcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0sparcpy27-piddle-1.0.15nb3.tgz
NetBSD 9.0x86_64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0x86_64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0x86_64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0x86_64py27-piddle-1.0.15nb3.tgz
NetBSD 9.0x86_64py27-piddle-1.0.15nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.