graphics/libwmf - The NetBSD Packages Collection

Library for reading and converting WMF (Windows Meta Files)

libwmf is a library for UNIX-like machines that can convert wmf
(Windows Meta Files) files into other formats.  Currently it supports
a gd binding to convert to png, and an X one to draw direct to an X
window or pixmap. It also comes with a program to display wmfs: wmf2x.

Without a TrueType font server and the standard MS Windows fonts, the X
binding might render text in a different font than would appear under
MS Windows natively (this is a runtime issue for the wmf2x program).

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

graphics/freetype2 graphics/freetype2 graphics/jpeg graphics/png textproc/libxml2 graphics/jpeg graphics/png textproc/libxml2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibwmf-0.2.8.4nb18.tgz
NetBSD 8.0earmv7hflibwmf-0.2.8.4nb17.tgz
NetBSD 8.0earmv7hflibwmf-0.2.8.4nb18.tgz
NetBSD 8.0i386libwmf-0.2.8.4nb17.tgz
NetBSD 8.0i386libwmf-0.2.8.4nb18.tgz
NetBSD 8.0i386libwmf-0.2.8.4nb18.tgz
NetBSD 8.0i386libwmf-0.2.8.4nb19.tgz
NetBSD 8.0powerpclibwmf-0.2.8.4nb17.tgz
NetBSD 8.0powerpclibwmf-0.2.8.4nb18.tgz
NetBSD 8.0powerpclibwmf-0.2.8.4nb18.tgz
NetBSD 8.0powerpclibwmf-0.2.8.4nb18.tgz
NetBSD 8.0x86_64libwmf-0.2.8.4nb18.tgz
NetBSD 8.0x86_64libwmf-0.2.8.4nb17.tgz
NetBSD 8.0x86_64libwmf-0.2.8.4nb18.tgz
NetBSD 8.0x86_64libwmf-0.2.8.4nb19.tgz
NetBSD 9.0aarch64libwmf-0.2.8.4nb19.tgz
NetBSD 9.0aarch64libwmf-0.2.8.4nb17.tgz
NetBSD 9.0aarch64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0aarch64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0alphalibwmf-0.2.8.4nb18.tgz
NetBSD 9.0alphalibwmf-0.2.8.4nb19.tgz
NetBSD 9.0earmlibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmlibwmf-0.2.8.4nb19.tgz
NetBSD 9.0earmv6hflibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmv6hflibwmf-0.2.8.4nb17.tgz
NetBSD 9.0earmv6hflibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmv6hflibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmv6hflibwmf-0.2.8.4nb19.tgz
NetBSD 9.0earmv7hflibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmv7hflibwmf-0.2.8.4nb17.tgz
NetBSD 9.0earmv7hflibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmv7hflibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmv7hflibwmf-0.2.8.4nb18.tgz
NetBSD 9.0earmv7hflibwmf-0.2.8.4nb19.tgz
NetBSD 9.0earmv7hflibwmf-0.2.8.4nb19.tgz
NetBSD 9.0i386libwmf-0.2.8.4nb17.tgz
NetBSD 9.0i386libwmf-0.2.8.4nb18.tgz
NetBSD 9.0i386libwmf-0.2.8.4nb18.tgz
NetBSD 9.0i386libwmf-0.2.8.4nb19.tgz
NetBSD 9.0m68klibwmf-0.2.8.4nb18.tgz
NetBSD 9.0m68klibwmf-0.2.8.4nb17.tgz
NetBSD 9.0mips64eblibwmf-0.2.8.4nb18.tgz
NetBSD 9.0mips64eblibwmf-0.2.8.4nb17.tgz
NetBSD 9.0mips64eblibwmf-0.2.8.4nb18.tgz
NetBSD 9.0mips64eblibwmf-0.2.8.4nb19.tgz
NetBSD 9.0mipsellibwmf-0.2.8.4nb18.tgz
NetBSD 9.0mipsellibwmf-0.2.8.4nb18.tgz
NetBSD 9.0powerpclibwmf-0.2.8.4nb18.tgz
NetBSD 9.0powerpclibwmf-0.2.8.4nb17.tgz
NetBSD 9.0powerpclibwmf-0.2.8.4nb18.tgz
NetBSD 9.0powerpclibwmf-0.2.8.4nb18.tgz
NetBSD 9.0powerpclibwmf-0.2.8.4nb18.tgz
NetBSD 9.0sh3ellibwmf-0.2.8.4nb18.tgz
NetBSD 9.0sh3ellibwmf-0.2.8.4nb18.tgz
NetBSD 9.0sparc64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0sparc64libwmf-0.2.8.4nb19.tgz
NetBSD 9.0sparclibwmf-0.2.8.4nb18.tgz
NetBSD 9.0sparclibwmf-0.2.8.4nb17.tgz
NetBSD 9.0sparclibwmf-0.2.8.4nb18.tgz
NetBSD 9.0sparclibwmf-0.2.8.4nb19.tgz
NetBSD 9.0vaxlibwmf-0.2.8.4nb18.tgz
NetBSD 9.0vaxlibwmf-0.2.8.4nb18.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb19.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb17.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb18.tgz
NetBSD 9.0x86_64libwmf-0.2.8.4nb19.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.