finance/py-crytic-compile - The NetBSD Packages Collection

Abstraction layer for smart contract build systems

Library to help smart contract compilation. It includes support for:
- Direct solc compilation
- Truffle
- Embark
- Dapp
- Etherlime
- Etherscan
- Brownie
- Waffle
- Buidler

The plugin is used in Crytic tools, including:
- Slither
- Echidna
- Manticore
- evm-cfg-builder

Build dependencies

devel/py-setuptools devel/py-wheel devel/py-build misc/py-installer pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/py-cbor2 security/py-cryptodome lang/py-solc-select lang/python311 lang/python311

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64py310-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64py311-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64py312-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64py38-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64py39-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64py310-crytic-compile-0.3.1.tgz
NetBSD 10.0aarch64py311-crytic-compile-0.3.1.tgz
NetBSD 10.0aarch64py312-crytic-compile-0.3.1.tgz
NetBSD 10.0aarch64py38-crytic-compile-0.3.1.tgz
NetBSD 10.0aarch64py39-crytic-compile-0.3.1.tgz
NetBSD 10.0aarch64ebpy310-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64ebpy311-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64ebpy312-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64ebpy38-crytic-compile-0.3.6.tgz
NetBSD 10.0aarch64ebpy39-crytic-compile-0.3.6.tgz
NetBSD 10.0alphapy310-crytic-compile-0.3.6.tgz
NetBSD 10.0alphapy311-crytic-compile-0.3.6.tgz
NetBSD 10.0alphapy312-crytic-compile-0.3.6.tgz
NetBSD 10.0alphapy38-crytic-compile-0.3.6.tgz
NetBSD 10.0alphapy39-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv4py310-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv6hfpy310-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv6hfpy311-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv6hfpy312-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv6hfpy38-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv6hfpy39-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv6hfpy310-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv6hfpy311-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv6hfpy312-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv6hfpy38-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv6hfpy39-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv7hfpy310-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv7hfpy311-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv7hfpy312-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv7hfpy38-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv7hfpy39-crytic-compile-0.3.6.tgz
NetBSD 10.0earmv7hfpy310-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv7hfpy311-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv7hfpy312-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv7hfpy38-crytic-compile-0.3.1.tgz
NetBSD 10.0earmv7hfpy39-crytic-compile-0.3.1.tgz
NetBSD 10.0i386py310-crytic-compile-0.3.6.tgz
NetBSD 10.0i386py311-crytic-compile-0.3.6.tgz
NetBSD 10.0i386py312-crytic-compile-0.3.6.tgz
NetBSD 10.0i386py38-crytic-compile-0.3.6.tgz
NetBSD 10.0i386py39-crytic-compile-0.3.6.tgz
NetBSD 10.0i386py310-crytic-compile-0.3.1.tgz
NetBSD 10.0i386py311-crytic-compile-0.3.1.tgz
NetBSD 10.0i386py312-crytic-compile-0.3.1.tgz
NetBSD 10.0i386py38-crytic-compile-0.3.1.tgz
NetBSD 10.0i386py39-crytic-compile-0.3.1.tgz
NetBSD 10.0mips64ebpy310-crytic-compile-0.3.6.tgz
NetBSD 10.0powerpcpy310-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy311-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy38-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy39-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy310-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy311-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy312-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy38-crytic-compile-0.3.1.tgz
NetBSD 10.0powerpcpy39-crytic-compile-0.3.1.tgz
NetBSD 10.0sh3elpy310-crytic-compile-0.3.1.tgz
NetBSD 10.0sh3elpy38-crytic-compile-0.3.1.tgz
NetBSD 10.0sh3elpy39-crytic-compile-0.3.1.tgz
NetBSD 10.0sh3elpy310-crytic-compile-0.3.6.tgz
NetBSD 10.0sh3elpy38-crytic-compile-0.3.6.tgz
NetBSD 10.0sparc64py310-crytic-compile-0.3.6.tgz
NetBSD 10.0sparc64py311-crytic-compile-0.3.6.tgz
NetBSD 10.0sparc64py312-crytic-compile-0.3.6.tgz
NetBSD 10.0sparc64py38-crytic-compile-0.3.6.tgz
NetBSD 10.0sparc64py39-crytic-compile-0.3.6.tgz
NetBSD 10.0sparcpy310-crytic-compile-0.3.6.tgz
NetBSD 10.0sparcpy38-crytic-compile-0.3.6.tgz
NetBSD 10.0sparcpy39-crytic-compile-0.3.6.tgz
NetBSD 10.0x86_64py310-crytic-compile-0.3.6.tgz
NetBSD 10.0x86_64py311-crytic-compile-0.3.6.tgz
NetBSD 10.0x86_64py312-crytic-compile-0.3.6.tgz
NetBSD 10.0x86_64py38-crytic-compile-0.3.6.tgz
NetBSD 10.0x86_64py39-crytic-compile-0.3.6.tgz
NetBSD 10.0x86_64py310-crytic-compile-0.3.1.tgz
NetBSD 10.0x86_64py311-crytic-compile-0.3.1.tgz
NetBSD 10.0x86_64py312-crytic-compile-0.3.1.tgz
NetBSD 10.0x86_64py38-crytic-compile-0.3.1.tgz
NetBSD 10.0x86_64py39-crytic-compile-0.3.1.tgz
NetBSD 9.0aarch64py310-crytic-compile-0.3.6.tgz
NetBSD 9.0aarch64py311-crytic-compile-0.3.6.tgz
NetBSD 9.0aarch64py312-crytic-compile-0.3.6.tgz
NetBSD 9.0aarch64py38-crytic-compile-0.3.6.tgz
NetBSD 9.0aarch64py39-crytic-compile-0.3.6.tgz
NetBSD 9.0aarch64py310-crytic-compile-0.3.1.tgz
NetBSD 9.0aarch64py311-crytic-compile-0.3.1.tgz
NetBSD 9.0aarch64py312-crytic-compile-0.3.1.tgz
NetBSD 9.0aarch64py38-crytic-compile-0.3.1.tgz
NetBSD 9.0aarch64py39-crytic-compile-0.3.1.tgz
NetBSD 9.0alphapy310-crytic-compile-0.3.6.tgz
NetBSD 9.0alphapy311-crytic-compile-0.3.6.tgz
NetBSD 9.0alphapy38-crytic-compile-0.3.6.tgz
NetBSD 9.0alphapy39-crytic-compile-0.3.6.tgz
NetBSD 9.0earmpy310-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0earmpy311-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0earmpy37-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0earmpy38-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0earmpy39-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0earmv4py310-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv6hfpy310-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv6hfpy311-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv6hfpy38-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv6hfpy39-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv6hfpy310-crytic-compile-0.3.1.tgz
NetBSD 9.0earmv6hfpy311-crytic-compile-0.3.1.tgz
NetBSD 9.0earmv6hfpy38-crytic-compile-0.3.1.tgz
NetBSD 9.0earmv6hfpy39-crytic-compile-0.3.1.tgz
NetBSD 9.0earmv7hfpy310-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv7hfpy311-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv7hfpy38-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv7hfpy39-crytic-compile-0.3.6.tgz
NetBSD 9.0earmv7hfpy310-crytic-compile-0.3.1.tgz
NetBSD 9.0earmv7hfpy311-crytic-compile-0.3.1.tgz
NetBSD 9.0earmv7hfpy38-crytic-compile-0.3.1.tgz
NetBSD 9.0earmv7hfpy39-crytic-compile-0.3.1.tgz
NetBSD 9.0i386py310-crytic-compile-0.3.6.tgz
NetBSD 9.0i386py311-crytic-compile-0.3.6.tgz
NetBSD 9.0i386py312-crytic-compile-0.3.6.tgz
NetBSD 9.0i386py38-crytic-compile-0.3.6.tgz
NetBSD 9.0i386py39-crytic-compile-0.3.6.tgz
NetBSD 9.0i386py310-crytic-compile-0.3.1.tgz
NetBSD 9.0i386py311-crytic-compile-0.3.1.tgz
NetBSD 9.0i386py38-crytic-compile-0.3.1.tgz
NetBSD 9.0i386py39-crytic-compile-0.3.1.tgz
NetBSD 9.0mips64ebpy310-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0mips64ebpy311-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0mips64ebpy37-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0mips64ebpy38-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0mips64ebpy39-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0mipselpy310-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0mipselpy39-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0powerpcpy310-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy311-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy312-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy38-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy39-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy310-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy311-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy38-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy39-crytic-compile-0.3.1.tgz
NetBSD 9.0powerpcpy310-crytic-compile-0.3.6.tgz
NetBSD 9.0powerpcpy311-crytic-compile-0.3.6.tgz
NetBSD 9.0powerpcpy312-crytic-compile-0.3.6.tgz
NetBSD 9.0powerpcpy38-crytic-compile-0.3.6.tgz
NetBSD 9.0powerpcpy39-crytic-compile-0.3.6.tgz
NetBSD 9.0sh3elpy310-crytic-compile-0.3.1.tgz
NetBSD 9.0sh3elpy38-crytic-compile-0.3.1.tgz
NetBSD 9.0sh3elpy39-crytic-compile-0.3.1.tgz
NetBSD 9.0sparc64py310-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0sparc64py311-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0sparc64py37-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0sparc64py38-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0sparc64py39-crytic-compile-0.1.9nb2.tgz
NetBSD 9.0sparc64py310-crytic-compile-0.3.6.tgz
NetBSD 9.0sparcpy310-crytic-compile-0.3.1.tgz
NetBSD 9.0x86_64py310-crytic-compile-0.3.6.tgz
NetBSD 9.0x86_64py311-crytic-compile-0.3.6.tgz
NetBSD 9.0x86_64py312-crytic-compile-0.3.6.tgz
NetBSD 9.0x86_64py38-crytic-compile-0.3.6.tgz
NetBSD 9.0x86_64py39-crytic-compile-0.3.6.tgz
NetBSD 9.0x86_64py310-crytic-compile-0.3.1.tgz
NetBSD 9.0x86_64py311-crytic-compile-0.3.1.tgz
NetBSD 9.0x86_64py312-crytic-compile-0.3.1.tgz
NetBSD 9.0x86_64py38-crytic-compile-0.3.1.tgz
NetBSD 9.0x86_64py39-crytic-compile-0.3.1.tgz
NetBSD 9.3x86_64py310-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py311-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py312-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py38-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py39-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py310-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py311-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py312-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py38-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py39-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py310-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py311-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py312-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py38-crytic-compile-0.3.7.tgz
NetBSD 9.3x86_64py39-crytic-compile-0.3.7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.