emulators/bochs - The NetBSD Packages Collection

IA32 and AMD64 PC emulator

The program bochs is a highly portable open source x86 PC emulator
written in C++, and runs on most popular platforms.  It includes
emulation of the Intel x86 CPU, common IO devices, and a custom
BIOS.  Currently, bochs can be compiled to emulate a 386, 486,
Pentium, Pentium PRO or AMD64 CPU.

Bochs is capable of running most operating systems inside the
emulation including Linux, NetBSD, Windows 95, DOS, and Windows NT 4.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

x11/libXpm x11/liboldXrandr x11/liboldXrandr x11/liboldXrandr

Available binary packages

aarch64:bochs-2.6.9nb3.tgz(NetBSD 9.0)
aarch64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
aarch64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
alpha:bochs-2.6.9nb4.tgz(NetBSD 9.0)
alpha:bochs-2.6.9nb4.tgz(NetBSD 9.0)
earmv6hf:bochs-2.6.9nb4.tgz(NetBSD 9.0)
earmv6hf:bochs-2.6.9nb3.tgz(NetBSD 9.0)
earmv6hf:bochs-2.6.9nb4.tgz(NetBSD 9.0)
earmv6hf:bochs-2.6.9nb4.tgz(NetBSD 9.0)
earmv7hf:bochs-2.6.9nb4.tgz(NetBSD 8.0)
earmv7hf:bochs-2.6.9nb3.tgz(NetBSD 8.0)
earmv7hf:bochs-2.6.9nb3.tgz(NetBSD 8.0)
earmv7hf:bochs-2.6.9nb4.tgz(NetBSD 9.0)
earmv7hf:bochs-2.6.9nb3.tgz(NetBSD 9.0)
earmv7hf:bochs-2.6.9nb3.tgz(NetBSD 9.0)
earmv7hf:bochs-2.6.9nb4.tgz(NetBSD 9.0)
earmv7hf:bochs-2.6.9nb4.tgz(NetBSD 9.0)
i386:bochs-2.6.9nb3.tgz(NetBSD 8.0)
i386:bochs-2.6.9nb4.tgz(NetBSD 8.0)
i386:bochs-2.6.9nb4.tgz(NetBSD 8.0)
i386:bochs-2.6.9nb3.tgz(NetBSD 9.0)
i386:bochs-2.6.9nb4.tgz(NetBSD 9.0)
i386:bochs-2.6.9nb4.tgz(NetBSD 9.0)
m68k:bochs-2.6.9nb4.tgz(NetBSD 9.0)
mips64eb:bochs-2.6.9nb4.tgz(NetBSD 9.0)
powerpc:bochs-2.6.9nb3.tgz(NetBSD 8.0)
powerpc:bochs-2.6.9nb4.tgz(NetBSD 8.0)
powerpc:bochs-2.6.9nb4.tgz(NetBSD 8.0)
powerpc:bochs-2.6.9nb4.tgz(NetBSD 9.0)
powerpc:bochs-2.6.9nb3.tgz(NetBSD 9.0)
sparc64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
sparc64:bochs-2.6.9nb3.tgz(NetBSD 9.0)
sparc64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
sparc:bochs-2.6.9nb4.tgz(NetBSD 9.0)
vax:bochs-2.6.9nb4.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 8.0)
x86_64:bochs-2.6.9nb3.tgz(NetBSD 8.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 8.0)
x86_64:bochs-2.6.9nb3.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 9.0)
x86_64:bochs-2.6.9nb4.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

debug
Enable debugging facilities in the package.
tiny
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]