editors/emacs21 - The NetBSD Packages Collection

GNU editing macros (editor)

GNU Emacs is a self-documenting, customizable, extensible real-time
display editor.

Users new to Emacs will be able to use basic features fairly rapidly
by studying the tutorial and using the self-documentation features.
Emacs also has an extensive interactive manual browser.  It is easily
extensible since its editing commands are written in Lisp.

GNU Emacs's many special packages handle mail reading (RMail) and
sending (Mail), outline editing (Outline), compiling (Compile),
running subshells within Emacs windows (Shell), running a Lisp
read-eval-print loop (Lisp-Interaction-Mode), automated psychotherapy
(Doctor :-) and many more.

This package contains Emacs version 21.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/gmake devel/imake

Runtime dependencies

lang/perl5 graphics/jpeg graphics/tiff graphics/png x11/libXpm graphics/giflib graphics/jpeg graphics/tiff graphics/png graphics/giflib

Available binary packages

earm:emacs21-21.4anb41.tgz(NetBSD 9.0)
earmv6hf:emacs21-21.4anb43.tgz(NetBSD 9.0)
earmv6hf:emacs21-21.4anb42.tgz(NetBSD 9.0)
earmv6hf:emacs21-21.4anb43.tgz(NetBSD 9.0)
earmv6hf:emacs21-21.4anb43.tgz(NetBSD 9.0)
earmv7hf:emacs21-21.4anb43.tgz(NetBSD 8.0)
earmv7hf:emacs21-21.4anb41.tgz(NetBSD 8.0)
earmv7hf:emacs21-21.4anb42.tgz(NetBSD 8.0)
earmv7hf:emacs21-21.4anb43.tgz(NetBSD 9.0)
earmv7hf:emacs21-21.4anb41.tgz(NetBSD 9.0)
earmv7hf:emacs21-21.4anb42.tgz(NetBSD 9.0)
earmv7hf:emacs21-21.4anb43.tgz(NetBSD 9.0)
earmv7hf:emacs21-21.4anb43.tgz(NetBSD 9.0)
i386:emacs21-21.4anb42.tgz(NetBSD 8.0)
i386:emacs21-21.4anb43.tgz(NetBSD 8.0)
i386:emacs21-21.4anb43.tgz(NetBSD 8.0)
i386:emacs21-21.4anb42.tgz(NetBSD 9.0)
i386:emacs21-21.4anb43.tgz(NetBSD 9.0)
i386:emacs21-21.4anb43.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 8.0)
x86_64:emacs21-21.4anb42.tgz(NetBSD 8.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 8.0)
x86_64:emacs21-21.4anb42.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 9.0)
x86_64:emacs21-21.4anb43.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

x11
Enable X11 support.
motif
Enable motif support.
xaw
Enable Xaw support.
xaw3d
Enable Xaw3D support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]