devel/samurai - The NetBSD Packages Collection

Ninja-compatible build tool written in C

samurai is a ninja-compatible build tool written in C99 with a focus on
simplicity, speed, and portability.

samurai implements the ninja build language through version 1.9.0 except
for MSVC dependency handling (`deps = msvc`). It uses the same format
for `.ninja_log` and `.ninja_deps` as ninja, currently version 5 and 4
respectively.

It is feature-complete and supports most of the same options as ninja.

samurai requires various POSIX.1-2008 interfaces.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsamurai-1.2.tgz
NetBSD 8.0earmv7hfsamurai-1.2.tgz
NetBSD 8.0earmv7hfsamurai-1.2.tgz
NetBSD 8.0i386samurai-1.2.tgz
NetBSD 8.0i386samurai-1.2.tgz
NetBSD 8.0powerpcsamurai-1.2.tgz
NetBSD 8.0powerpcsamurai-1.2.tgz
NetBSD 8.0powerpcsamurai-1.2.tgz
NetBSD 8.0powerpcsamurai-1.2.tgz
NetBSD 8.0x86_64samurai-1.2.tgz
NetBSD 8.0x86_64samurai-1.2.tgz
NetBSD 9.0aarch64samurai-1.2.tgz
NetBSD 9.0aarch64samurai-1.2.tgz
NetBSD 9.0aarch64samurai-1.2.tgz
NetBSD 9.0alphasamurai-1.2.tgz
NetBSD 9.0alphasamurai-1.2.tgz
NetBSD 9.0alphasamurai-1.2.tgz
NetBSD 9.0earmsamurai-1.2.tgz
NetBSD 9.0earmsamurai-1.2.tgz
NetBSD 9.0earmsamurai-1.2.tgz
NetBSD 9.0earmv6hfsamurai-1.2.tgz
NetBSD 9.0earmv6hfsamurai-1.2.tgz
NetBSD 9.0earmv6hfsamurai-1.2.tgz
NetBSD 9.0earmv7hfsamurai-1.2.tgz
NetBSD 9.0earmv7hfsamurai-1.2.tgz
NetBSD 9.0earmv7hfsamurai-1.2.tgz
NetBSD 9.0earmv7hfsamurai-1.2.tgz
NetBSD 9.0i386samurai-1.2.tgz
NetBSD 9.0i386samurai-1.2.tgz
NetBSD 9.0i386samurai-1.2.tgz
NetBSD 9.0mips64ebsamurai-1.2.tgz
NetBSD 9.0mips64ebsamurai-1.1.tgz
NetBSD 9.0mips64ebsamurai-1.2.tgz
NetBSD 9.0mips64ebsamurai-1.2.tgz
NetBSD 9.0mips64ebsamurai-1.2.tgz
NetBSD 9.0powerpcsamurai-1.2.tgz
NetBSD 9.0powerpcsamurai-1.2.tgz
NetBSD 9.0powerpcsamurai-1.2.tgz
NetBSD 9.0powerpcsamurai-1.2.tgz
NetBSD 9.0sparc64samurai-1.2.tgz
NetBSD 9.0sparc64samurai-1.2.tgz
NetBSD 9.0sparc64samurai-1.2.tgz
NetBSD 9.0sparcsamurai-1.2.tgz
NetBSD 9.0sparcsamurai-1.1.tgz
NetBSD 9.0sparcsamurai-1.2.tgz
NetBSD 9.0sparcsamurai-1.2.tgz
NetBSD 9.0sparcsamurai-1.2.tgz
NetBSD 9.0x86_64samurai-1.2.tgz
NetBSD 9.0x86_64samurai-1.2.tgz
NetBSD 9.0x86_64samurai-1.2.tgz
NetBSD 9.0x86_64samurai-1.2.tgz
NetBSD 9.0x86_64samurai-1.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.