devel/ruby-tty-reader - The NetBSD Packages Collection

Set of methods for processing keyboard input

TTY::Reader

> A pure Ruby library that provides a set of methods for processing keyboard
  input in character, line and multiline modes. It maintains history of
  entered input with an ability to recall and re-edit those inputs. It lets
  you register to listen for keystroke events and trigger custom key events
  yourself.

TTY::Reader provides independent reader component for TTY
(https://github.com/piotrmurach/tty) toolkit.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/ruby-wisper devel/ruby-tty-screen devel/ruby-tty-cursor lang/ruby27-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby26-tty-reader-0.9.0.tgz
NetBSD 8.0earmv7hfruby27-tty-reader-0.9.0.tgz
NetBSD 8.0earmv7hfruby25-tty-reader-0.9.0.tgz
NetBSD 8.0earmv7hfruby26-tty-reader-0.9.0.tgz
NetBSD 8.0earmv7hfruby27-tty-reader-0.9.0.tgz
NetBSD 8.0earmv7hfruby26-tty-reader-0.9.0.tgz
NetBSD 8.0earmv7hfruby27-tty-reader-0.9.0.tgz
NetBSD 8.0i386ruby25-tty-reader-0.9.0.tgz
NetBSD 8.0i386ruby26-tty-reader-0.9.0.tgz
NetBSD 8.0i386ruby27-tty-reader-0.9.0.tgz
NetBSD 8.0i386ruby26-tty-reader-0.9.0.tgz
NetBSD 8.0i386ruby27-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby25-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby25-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby25-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby25-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 8.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 8.0x86_64ruby25-tty-reader-0.9.0.tgz
NetBSD 8.0x86_64ruby26-tty-reader-0.9.0.tgz
NetBSD 8.0x86_64ruby27-tty-reader-0.9.0.tgz
NetBSD 8.0x86_64ruby26-tty-reader-0.9.0.tgz
NetBSD 8.0x86_64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby25-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0aarch64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby25-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby26-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby27-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby25-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby26-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby27-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby25-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby26-tty-reader-0.9.0.tgz
NetBSD 9.0alpharuby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmruby30-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby30-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby25-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby30-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmv6hfruby30-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby30-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby25-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby30-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby30-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby26-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby27-tty-reader-0.9.0.tgz
NetBSD 9.0earmv7hfruby30-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby25-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0i386ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby25-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby26-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby27-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby30-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby25-tty-reader-0.8.0.tgz
NetBSD 9.0mips64ebruby26-tty-reader-0.8.0.tgz
NetBSD 9.0mips64ebruby27-tty-reader-0.8.0.tgz
NetBSD 9.0mips64ebruby25-tty-reader-0.8.0.tgz
NetBSD 9.0mips64ebruby26-tty-reader-0.8.0.tgz
NetBSD 9.0mips64ebruby27-tty-reader-0.8.0.tgz
NetBSD 9.0mips64ebruby25-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby26-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby27-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby30-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby25-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby26-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby27-tty-reader-0.9.0.tgz
NetBSD 9.0mips64ebruby30-tty-reader-0.9.0.tgz
NetBSD 9.0mipselruby27-tty-reader-0.9.0.tgz
NetBSD 9.0mipselruby30-tty-reader-0.9.0.tgz
NetBSD 9.0mipselruby27-tty-reader-0.8.0.tgz
NetBSD 9.0mipselruby27-tty-reader-0.9.0.tgz
NetBSD 9.0mipselruby30-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby25-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby30-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby25-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby30-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby25-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby30-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby26-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby27-tty-reader-0.9.0.tgz
NetBSD 9.0powerpcruby30-tty-reader-0.9.0.tgz
NetBSD 9.0sh3elruby25-tty-reader-0.8.0.tgz
NetBSD 9.0sparc64ruby25-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby25-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby25-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0sparc64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0sparcruby27-tty-reader-0.9.0.tgz
NetBSD 9.0sparcruby30-tty-reader-0.9.0.tgz
NetBSD 9.0sparcruby25-tty-reader-0.8.0.tgz
NetBSD 9.0sparcruby27-tty-reader-0.8.0.tgz
NetBSD 9.0sparcruby25-tty-reader-0.8.0.tgz
NetBSD 9.0sparcruby27-tty-reader-0.8.0.tgz
NetBSD 9.0sparcruby27-tty-reader-0.9.0.tgz
NetBSD 9.0sparcruby30-tty-reader-0.9.0.tgz
NetBSD 9.0sparcruby27-tty-reader-0.9.0.tgz
NetBSD 9.0sparcruby30-tty-reader-0.9.0.tgz
NetBSD 9.0vaxruby27-tty-reader-0.8.0.tgz
NetBSD 9.0x86_64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby25-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby30-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby26-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby27-tty-reader-0.9.0.tgz
NetBSD 9.0x86_64ruby30-tty-reader-0.9.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.