devel/ruby-rspec-rails - The NetBSD Packages Collection

Test-double framework for rspec

# rspec-rails-2

rspec-2 for rails-3 with lightweight extensions to each

NOTE: rspec-2 does _not_ support rails-2. Use rspec-rails-1.3.x for rails-2.

## Documentation

* [Cucumber features](http://relishapp.com/rspec/rspec-rails/v/2-0)
* [RDoc](http://rubydoc.info/gems/rspec-rails/2.0.1/frames)

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/ruby-activesupport52 www/ruby-actionpack52 devel/ruby-railties52 devel/ruby-rspec-support devel/ruby-rspec-core devel/ruby-rspec-expectations devel/ruby-rspec-mocks lang/ruby26-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0earmv7hfruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0earmv7hfruby27-rspec-rails-4.0.1.tgz
NetBSD 8.0earmv7hfruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0earmv7hfruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0earmv7hfruby27-rspec-rails-4.0.1.tgz
NetBSD 8.0earmv7hfruby25-rspec-rails-5.0.1.tgz
NetBSD 8.0earmv7hfruby26-rspec-rails-5.0.1.tgz
NetBSD 8.0earmv7hfruby27-rspec-rails-5.0.1.tgz
NetBSD 8.0i386ruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0i386ruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0i386ruby27-rspec-rails-4.0.1.tgz
NetBSD 8.0i386ruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0i386ruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0i386ruby27-rspec-rails-4.0.1.tgz
NetBSD 8.0i386ruby25-rspec-rails-5.0.1.tgz
NetBSD 8.0i386ruby26-rspec-rails-5.0.1.tgz
NetBSD 8.0i386ruby27-rspec-rails-5.0.1.tgz
NetBSD 8.0powerpcruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0powerpcruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0powerpcruby27-rspec-rails-4.0.1.tgz
NetBSD 8.0powerpcruby25-rspec-rails-5.0.1.tgz
NetBSD 8.0powerpcruby26-rspec-rails-5.0.1.tgz
NetBSD 8.0powerpcruby27-rspec-rails-5.0.1.tgz
NetBSD 8.0powerpcruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0powerpcruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0powerpcruby27-rspec-rails-4.0.1.tgz
NetBSD 8.0powerpcruby25-rspec-rails-5.0.1.tgz
NetBSD 8.0powerpcruby26-rspec-rails-5.0.1.tgz
NetBSD 8.0powerpcruby27-rspec-rails-5.0.1.tgz
NetBSD 8.0x86_64ruby25-rspec-rails-5.0.1.tgz
NetBSD 8.0x86_64ruby26-rspec-rails-5.0.1.tgz
NetBSD 8.0x86_64ruby27-rspec-rails-5.0.1.tgz
NetBSD 8.0x86_64ruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0x86_64ruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0x86_64ruby27-rspec-rails-4.0.1.tgz
NetBSD 8.0x86_64ruby25-rspec-rails-4.0.1.tgz
NetBSD 8.0x86_64ruby26-rspec-rails-4.0.1.tgz
NetBSD 8.0x86_64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0aarch64ruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0aarch64ruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0aarch64ruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0aarch64ruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0aarch64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0aarch64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0aarch64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0aarch64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0aarch64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0aarch64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0alpharuby25-rspec-rails-5.0.1.tgz
NetBSD 9.0alpharuby26-rspec-rails-5.0.1.tgz
NetBSD 9.0alpharuby27-rspec-rails-5.0.1.tgz
NetBSD 9.0alpharuby25-rspec-rails-4.0.1.tgz
NetBSD 9.0alpharuby26-rspec-rails-4.0.1.tgz
NetBSD 9.0alpharuby27-rspec-rails-4.0.1.tgz
NetBSD 9.0alpharuby25-rspec-rails-4.0.1.tgz
NetBSD 9.0alpharuby26-rspec-rails-4.0.1.tgz
NetBSD 9.0alpharuby27-rspec-rails-4.0.1.tgz
NetBSD 9.0earmruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0earmruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv6hfruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv6hfruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv6hfruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv6hfruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv6hfruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv7hfruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv7hfruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv7hfruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv7hfruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0earmv7hfruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv7hfruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv7hfruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0earmv7hfruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0i386ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0i386ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0i386ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0i386ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0i386ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0i386ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0i386ruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0i386ruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0i386ruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0i386ruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0mips64ebruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0mips64ebruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0mips64ebruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0mips64ebruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0mips64ebruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0mips64ebruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0powerpcruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0powerpcruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0powerpcruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0powerpcruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0powerpcruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0powerpcruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0powerpcruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0powerpcruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0powerpcruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0powerpcruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0powerpcruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0powerpcruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0powerpcruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0powerpcruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0sparc64ruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0sparc64ruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0sparc64ruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0sparc64ruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0sparc64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0sparc64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0sparc64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0sparc64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0sparc64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0sparc64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0sparcruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby25-rspec-rails-4.0.2.tgz
NetBSD 9.0x86_64ruby26-rspec-rails-4.0.2.tgz
NetBSD 9.0x86_64ruby27-rspec-rails-4.0.2.tgz
NetBSD 9.0x86_64ruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0x86_64ruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0x86_64ruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0x86_64ruby30-rspec-rails-5.0.1.tgz
NetBSD 9.0x86_64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby25-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby26-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby27-rspec-rails-4.0.1.tgz
NetBSD 9.0x86_64ruby25-rspec-rails-5.0.1.tgz
NetBSD 9.0x86_64ruby26-rspec-rails-5.0.1.tgz
NetBSD 9.0x86_64ruby27-rspec-rails-5.0.1.tgz
NetBSD 9.0x86_64ruby30-rspec-rails-5.0.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.