devel/ruby-paint - The NetBSD Packages Collection

Terminal painter with RGB and 256 (fallback) color

Ruby Paint

Paint creates terminal colors and effects for you.  It combines the
strengths of term-ansicolor, rainbow, and similar projects into a simple to
use, however still flexible terminal colors gem with no core extensions by
default.

Features

* No string extensions (suitable for library development)
* Simple API
* Faster than other terminal color gems (as of July 2022)
* Supports true color or 256 colors (for capable terminals)
* Allows you to set any terminal effects
* Paint.mode: Fall-back modes for terminals with less colors, supported
  modes:

  o 0xFFFFFF (= 16777215) colors (true color)
  o 256 colors (palette)
  o 16 colors (only ANSI colors, combined with bright effect)
  o 8 colors (only ANSI colors)
  o 0 colors (no colors / deactivate)

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

lang/ruby31-base

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ruby27-paint-2.3.0.tgz
NetBSD 10.0aarch64ruby30-paint-2.3.0.tgz
NetBSD 10.0aarch64ruby31-paint-2.3.0.tgz
NetBSD 10.0earmv6hfruby27-paint-2.3.0.tgz
NetBSD 10.0earmv6hfruby30-paint-2.3.0.tgz
NetBSD 10.0earmv6hfruby31-paint-2.3.0.tgz
NetBSD 10.0earmv7hfruby27-paint-2.3.0.tgz
NetBSD 10.0earmv7hfruby30-paint-2.3.0.tgz
NetBSD 10.0earmv7hfruby31-paint-2.3.0.tgz
NetBSD 10.0x86_64ruby27-paint-2.3.0.tgz
NetBSD 10.0x86_64ruby30-paint-2.3.0.tgz
NetBSD 10.0x86_64ruby31-paint-2.3.0.tgz
NetBSD 8.0powerpcruby27-paint-2.3.0.tgz
NetBSD 8.0powerpcruby30-paint-2.3.0.tgz
NetBSD 8.0powerpcruby31-paint-2.3.0.tgz
NetBSD 8.0powerpcruby27-paint-2.3.0.tgz
NetBSD 8.0powerpcruby30-paint-2.3.0.tgz
NetBSD 8.0powerpcruby31-paint-2.3.0.tgz
NetBSD 9.0aarch64ruby27-paint-2.3.0.tgz
NetBSD 9.0aarch64ruby30-paint-2.3.0.tgz
NetBSD 9.0aarch64ruby31-paint-2.3.0.tgz
NetBSD 9.0alpharuby27-paint-2.3.0.tgz
NetBSD 9.0earmv6hfruby27-paint-2.3.0.tgz
NetBSD 9.0earmv6hfruby30-paint-2.3.0.tgz
NetBSD 9.0earmv6hfruby31-paint-2.3.0.tgz
NetBSD 9.0earmv7hfruby27-paint-2.3.0.tgz
NetBSD 9.0earmv7hfruby30-paint-2.3.0.tgz
NetBSD 9.0earmv7hfruby31-paint-2.3.0.tgz
NetBSD 9.0sparc64ruby27-paint-2.3.0.tgz
NetBSD 9.0sparc64ruby30-paint-2.3.0.tgz
NetBSD 9.0sparc64ruby31-paint-2.3.0.tgz
NetBSD 9.0sparcruby27-paint-2.3.0.tgz
NetBSD 9.0sparcruby30-paint-2.3.0.tgz
NetBSD 9.0sparcruby31-paint-2.3.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.