devel/ruby-optimist - The NetBSD Packages Collection

Commandline option parser for Ruby

optimist

Description

Optimist is a commandline option parser for Ruby that just gets out of your
way.  One line of code per option is all you need to write.  For that, you
get a nice automatically-generated help page, robust option parsing, and
sensible defaults for everything you don't specify.

Features

* Dirt-simple usage.
* Single file.  Throw it in lib/ if you don't want to make it a Rubygem
  dependency.
* Sensible defaults.  No tweaking necessary, much tweaking possible.
* Support for long options, short options, subcommands, and automatic type
  validation and conversion.
* Automatic help message generation, wrapped to current screen width.

Requirements

* A burning desire to write less code.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

lang/ruby31-base

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ruby27-optimist-3.0.1.tgz
NetBSD 10.0aarch64ruby30-optimist-3.0.1.tgz
NetBSD 10.0aarch64ruby31-optimist-3.0.1.tgz
NetBSD 10.0earmv6hfruby27-optimist-3.0.1.tgz
NetBSD 10.0earmv6hfruby30-optimist-3.0.1.tgz
NetBSD 10.0earmv6hfruby31-optimist-3.0.1.tgz
NetBSD 10.0earmv7hfruby27-optimist-3.0.1.tgz
NetBSD 10.0earmv7hfruby30-optimist-3.0.1.tgz
NetBSD 10.0earmv7hfruby31-optimist-3.0.1.tgz
NetBSD 10.0x86_64ruby27-optimist-3.0.1.tgz
NetBSD 10.0x86_64ruby30-optimist-3.0.1.tgz
NetBSD 10.0x86_64ruby31-optimist-3.0.1.tgz
NetBSD 8.0powerpcruby27-optimist-3.0.1.tgz
NetBSD 8.0powerpcruby30-optimist-3.0.1.tgz
NetBSD 8.0powerpcruby31-optimist-3.0.1.tgz
NetBSD 8.0powerpcruby27-optimist-3.0.1.tgz
NetBSD 8.0powerpcruby30-optimist-3.0.1.tgz
NetBSD 8.0powerpcruby31-optimist-3.0.1.tgz
NetBSD 9.0aarch64ruby27-optimist-3.0.1.tgz
NetBSD 9.0aarch64ruby30-optimist-3.0.1.tgz
NetBSD 9.0aarch64ruby31-optimist-3.0.1.tgz
NetBSD 9.0alpharuby27-optimist-3.0.1.tgz
NetBSD 9.0earmv6hfruby27-optimist-3.0.1.tgz
NetBSD 9.0earmv6hfruby30-optimist-3.0.1.tgz
NetBSD 9.0earmv6hfruby31-optimist-3.0.1.tgz
NetBSD 9.0earmv7hfruby27-optimist-3.0.1.tgz
NetBSD 9.0earmv7hfruby30-optimist-3.0.1.tgz
NetBSD 9.0earmv7hfruby31-optimist-3.0.1.tgz
NetBSD 9.0sparc64ruby27-optimist-3.0.1.tgz
NetBSD 9.0sparc64ruby30-optimist-3.0.1.tgz
NetBSD 9.0sparc64ruby31-optimist-3.0.1.tgz
NetBSD 9.0sparcruby27-optimist-3.0.1.tgz
NetBSD 9.0sparcruby30-optimist-3.0.1.tgz
NetBSD 9.0sparcruby31-optimist-3.0.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.