devel/py-pqueue - The NetBSD Packages Collection

Priority-queues using fibonacci heaps

This C extension implements a priority-queue object using a fibonacci
heap as the underlying data structure. This data structure supports
the following operations with the given amortized time-complexity:

        - insert:       O(1)
        - find-min:     O(1)
        - extract-min:  O(lg N)
        - decrease-key: O(1)
        - increase-key: O(lg N)                 (== delete, insert)
        - delete:       O(lg N)                 (== decrease-key, extract-min)

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-pqueue-0.2nb1.tgz
NetBSD 8.0earmv7hfpy27-pqueue-0.2nb1.tgz
NetBSD 8.0earmv7hfpy27-pqueue-0.2nb1.tgz
NetBSD 8.0i386py27-pqueue-0.2nb1.tgz
NetBSD 8.0i386py27-pqueue-0.2nb1.tgz
NetBSD 8.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 8.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 8.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 8.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 8.0x86_64py27-pqueue-0.2nb1.tgz
NetBSD 8.0x86_64py27-pqueue-0.2nb1.tgz
NetBSD 9.0aarch64py27-pqueue-0.2nb1.tgz
NetBSD 9.0aarch64py27-pqueue-0.2nb1.tgz
NetBSD 9.0aarch64py27-pqueue-0.2nb1.tgz
NetBSD 9.0alphapy27-pqueue-0.2nb1.tgz
NetBSD 9.0alphapy27-pqueue-0.2nb1.tgz
NetBSD 9.0alphapy27-pqueue-0.2nb1.tgz
NetBSD 9.0earmv6hfpy27-pqueue-0.2nb1.tgz
NetBSD 9.0earmv6hfpy27-pqueue-0.2nb1.tgz
NetBSD 9.0earmv6hfpy27-pqueue-0.2nb1.tgz
NetBSD 9.0earmv7hfpy27-pqueue-0.2nb1.tgz
NetBSD 9.0earmv7hfpy27-pqueue-0.2nb1.tgz
NetBSD 9.0earmv7hfpy27-pqueue-0.2nb1.tgz
NetBSD 9.0earmv7hfpy27-pqueue-0.2nb1.tgz
NetBSD 9.0i386py27-pqueue-0.2nb1.tgz
NetBSD 9.0i386py27-pqueue-0.2nb1.tgz
NetBSD 9.0mips64ebpy27-pqueue-0.2nb1.tgz
NetBSD 9.0mips64ebpy27-pqueue-0.2nb1.tgz
NetBSD 9.0mips64ebpy27-pqueue-0.2nb1.tgz
NetBSD 9.0mips64ebpy27-pqueue-0.2nb1.tgz
NetBSD 9.0mips64ebpy27-pqueue-0.2nb1.tgz
NetBSD 9.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0powerpcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0sparc64py27-pqueue-0.2nb1.tgz
NetBSD 9.0sparc64py27-pqueue-0.2nb1.tgz
NetBSD 9.0sparc64py27-pqueue-0.2nb1.tgz
NetBSD 9.0sparcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0sparcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0sparcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0sparcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0sparcpy27-pqueue-0.2nb1.tgz
NetBSD 9.0x86_64py27-pqueue-0.2nb1.tgz
NetBSD 9.0x86_64py27-pqueue-0.2nb1.tgz
NetBSD 9.0x86_64py27-pqueue-0.2nb1.tgz
NetBSD 9.0x86_64py27-pqueue-0.2nb1.tgz
NetBSD 9.0x86_64py27-pqueue-0.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.