devel/popt - The NetBSD Packages Collection

Command line option parsing library

This is the popt command line option parsing library. While it is similar
to getopt(3), it contains a number of enhancements, including:

        1) popt is fully reentrant
        2) popt can parse arbitrary argv[] style arrays while
           getopt(2) makes this quite difficult
        3) popt allows users to alias command line arguments
        4) popt provides convenience functions for parsing strings
           into argv[] style arrays

popt is used by rpm, the Red Hat install program, and many other Red Hat
utilities, all of which provide excellent examples of how to use popt.
Complete documentation on popt is available in popt.ps (included in this
tarball), which is excerpted with permission from the book "Linux
Application Development" by Michael K. Johnson and Erik Troan (available
from Addison Wesley in May, 1998).

Comments on popt should be addressed to ewt@redhat.com.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpopt-1.18.tgz
NetBSD 8.0earmv7hfpopt-1.18.tgz
NetBSD 8.0earmv7hfpopt-1.18.tgz
NetBSD 8.0i386popt-1.18.tgz
NetBSD 8.0i386popt-1.18.tgz
NetBSD 8.0i386popt-1.18.tgz
NetBSD 8.0powerpcpopt-1.18.tgz
NetBSD 8.0powerpcpopt-1.18.tgz
NetBSD 8.0powerpcpopt-1.18.tgz
NetBSD 8.0x86_64popt-1.18.tgz
NetBSD 8.0x86_64popt-1.18.tgz
NetBSD 8.0x86_64popt-1.18.tgz
NetBSD 9.0aarch64popt-1.18.tgz
NetBSD 9.0aarch64popt-1.18.tgz
NetBSD 9.0aarch64popt-1.18.tgz
NetBSD 9.0alphapopt-1.18.tgz
NetBSD 9.0alphapopt-1.18.tgz
NetBSD 9.0alphapopt-1.18.tgz
NetBSD 9.0earmpopt-1.18.tgz
NetBSD 9.0earmpopt-1.18.tgz
NetBSD 9.0earmpopt-1.18.tgz
NetBSD 9.0earmv6hfpopt-1.18.tgz
NetBSD 9.0earmv6hfpopt-1.18.tgz
NetBSD 9.0earmv6hfpopt-1.18.tgz
NetBSD 9.0earmv6hfpopt-1.18.tgz
NetBSD 9.0earmv7hfpopt-1.18.tgz
NetBSD 9.0earmv7hfpopt-1.18.tgz
NetBSD 9.0earmv7hfpopt-1.18.tgz
NetBSD 9.0earmv7hfpopt-1.18.tgz
NetBSD 9.0i386popt-1.18.tgz
NetBSD 9.0i386popt-1.18.tgz
NetBSD 9.0i386popt-1.18.tgz
NetBSD 9.0m68kpopt-1.18.tgz
NetBSD 9.0m68kpopt-1.18.tgz
NetBSD 9.0m68kpopt-1.18.tgz
NetBSD 9.0mips64ebpopt-1.18.tgz
NetBSD 9.0mips64ebpopt-1.18.tgz
NetBSD 9.0mips64ebpopt-1.18.tgz
NetBSD 9.0mipselpopt-1.18.tgz
NetBSD 9.0mipselpopt-1.18.tgz
NetBSD 9.0powerpcpopt-1.18.tgz
NetBSD 9.0powerpcpopt-1.18.tgz
NetBSD 9.0sh3elpopt-1.18.tgz
NetBSD 9.0sh3elpopt-1.18.tgz
NetBSD 9.0sh3elpopt-1.18.tgz
NetBSD 9.0sparc64popt-1.18.tgz
NetBSD 9.0sparc64popt-1.16nb2.tgz
NetBSD 9.0sparc64popt-1.18.tgz
NetBSD 9.0sparc64popt-1.18.tgz
NetBSD 9.0sparcpopt-1.18.tgz
NetBSD 9.0sparcpopt-1.18.tgz
NetBSD 9.0sparcpopt-1.18.tgz
NetBSD 9.0vaxpopt-1.18.tgz
NetBSD 9.0vaxpopt-1.18.tgz
NetBSD 9.0vaxpopt-1.18.tgz
NetBSD 9.0x86_64popt-1.18.tgz
NetBSD 9.0x86_64popt-1.18.tgz
NetBSD 9.0x86_64popt-1.18.tgz
NetBSD 9.0x86_64popt-1.18.tgz
NetBSD 9.0x86_64popt-1.18.tgz
NetBSD 9.0x86_64popt-1.18.tgz
NetBSD 9.0x86_64popt-1.18.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.