devel/p5-autobox - The NetBSD Packages Collection

Perl 5 module to add methods on native types

The Perl 5 module autobox provides an autobox pragma.  It allows
methods to be called on integers, floats, strings, arrays, hashes,
and code references in exactly the same manner as blessed references.
The autoboxing is transparent: boxed values are not blessed into
their (user-defined) implementation class (unless the method elects
to bestow such a blessing) - they simply use its methods as though
they are.
The classes (packages) into which the native types are boxed are
fully configurable. By default, a method invoked on a non-object
is assumed to be defined in a class whose name corresponds to the
ref() type of that value - or SCALAR if the value is a non-reference.
This mapping can be overriden by passing key/value pairs to the use
autobox statement, in which the keys represent native types, and
the values their associated classes.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Scope-Guard devel/p5-IPC-System-Simple lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-autobox-3.0.1nb4.tgz
NetBSD 8.0earmv7hfp5-autobox-3.0.1nb3.tgz
NetBSD 8.0earmv7hfp5-autobox-3.0.1nb4.tgz
NetBSD 8.0i386p5-autobox-3.0.1nb3.tgz
NetBSD 8.0i386p5-autobox-3.0.1nb4.tgz
NetBSD 8.0powerpcp5-autobox-3.0.1nb3.tgz
NetBSD 8.0powerpcp5-autobox-3.0.1nb4.tgz
NetBSD 8.0powerpcp5-autobox-3.0.1nb4.tgz
NetBSD 8.0powerpcp5-autobox-3.0.1nb4.tgz
NetBSD 8.0x86_64p5-autobox-3.0.1nb3.tgz
NetBSD 8.0x86_64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0aarch64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0aarch64p5-autobox-3.0.1nb3.tgz
NetBSD 9.0aarch64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0alphap5-autobox-3.0.1nb4.tgz
NetBSD 9.0alphap5-autobox-3.0.1nb3.tgz
NetBSD 9.0alphap5-autobox-3.0.1nb4.tgz
NetBSD 9.0earmp5-autobox-3.0.1nb3.tgz
NetBSD 9.0earmp5-autobox-3.0.1nb4.tgz
NetBSD 9.0earmp5-autobox-3.0.1nb4.tgz
NetBSD 9.0earmv6hfp5-autobox-3.0.1nb4.tgz
NetBSD 9.0earmv6hfp5-autobox-3.0.1nb3.tgz
NetBSD 9.0earmv6hfp5-autobox-3.0.1nb4.tgz
NetBSD 9.0earmv7hfp5-autobox-3.0.1nb4.tgz
NetBSD 9.0earmv7hfp5-autobox-3.0.1nb3.tgz
NetBSD 9.0earmv7hfp5-autobox-3.0.1nb4.tgz
NetBSD 9.0earmv7hfp5-autobox-3.0.1nb4.tgz
NetBSD 9.0i386p5-autobox-3.0.1nb3.tgz
NetBSD 9.0i386p5-autobox-3.0.1nb4.tgz
NetBSD 9.0i386p5-autobox-3.0.1nb4.tgz
NetBSD 9.0m68kp5-autobox-3.0.1nb4.tgz
NetBSD 9.0m68kp5-autobox-3.0.1nb4.tgz
NetBSD 9.0mips64ebp5-autobox-3.0.1nb4.tgz
NetBSD 9.0mips64ebp5-autobox-3.0.1nb3.tgz
NetBSD 9.0mips64ebp5-autobox-3.0.1nb3.tgz
NetBSD 9.0mips64ebp5-autobox-3.0.1nb3.tgz
NetBSD 9.0mips64ebp5-autobox-3.0.1nb4.tgz
NetBSD 9.0mipselp5-autobox-3.0.1nb4.tgz
NetBSD 9.0mipselp5-autobox-3.0.1nb3.tgz
NetBSD 9.0mipselp5-autobox-3.0.1nb3.tgz
NetBSD 9.0mipselp5-autobox-3.0.1nb4.tgz
NetBSD 9.0powerpcp5-autobox-3.0.1nb4.tgz
NetBSD 9.0powerpcp5-autobox-3.0.1nb3.tgz
NetBSD 9.0powerpcp5-autobox-3.0.1nb4.tgz
NetBSD 9.0powerpcp5-autobox-3.0.1nb4.tgz
NetBSD 9.0sh3elp5-autobox-3.0.1nb4.tgz
NetBSD 9.0sh3elp5-autobox-3.0.1nb3.tgz
NetBSD 9.0sh3elp5-autobox-3.0.1nb3.tgz
NetBSD 9.0sh3elp5-autobox-3.0.1nb4.tgz
NetBSD 9.0sparc64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0sparc64p5-autobox-3.0.1nb3.tgz
NetBSD 9.0sparc64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0sparcp5-autobox-3.0.1nb4.tgz
NetBSD 9.0sparcp5-autobox-3.0.1nb3.tgz
NetBSD 9.0sparcp5-autobox-3.0.1nb3.tgz
NetBSD 9.0sparcp5-autobox-3.0.1nb3.tgz
NetBSD 9.0sparcp5-autobox-3.0.1nb4.tgz
NetBSD 9.0vaxp5-autobox-3.0.1nb3.tgz
NetBSD 9.0vaxp5-autobox-3.0.1nb3.tgz
NetBSD 9.0vaxp5-autobox-3.0.1nb4.tgz
NetBSD 9.0vaxp5-autobox-3.0.1nb4.tgz
NetBSD 9.0x86_64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0x86_64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0x86_64p5-autobox-3.0.1nb3.tgz
NetBSD 9.0x86_64p5-autobox-3.0.1nb4.tgz
NetBSD 9.0x86_64p5-autobox-3.0.1nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.