devel/p5-Shell-Perl - The NetBSD Packages Collection

Read-eval-print loop in Perl

The Perl 5 module Shell::Perl is the implementation of a command-line
interpreter for Perl. It is the heart of the provided pirl script.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Class-Accessor devel/p5-File-HomeDir devel/p5-Path-Class devel/p5-Test-Deep lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Shell-Perl-0.004nb4.tgz
NetBSD 8.0earmv7hfp5-Shell-Perl-0.004nb3.tgz
NetBSD 8.0earmv7hfp5-Shell-Perl-0.004nb4.tgz
NetBSD 8.0i386p5-Shell-Perl-0.004nb3.tgz
NetBSD 8.0i386p5-Shell-Perl-0.004nb4.tgz
NetBSD 8.0powerpcp5-Shell-Perl-0.004nb3.tgz
NetBSD 8.0powerpcp5-Shell-Perl-0.004nb4.tgz
NetBSD 8.0powerpcp5-Shell-Perl-0.004nb4.tgz
NetBSD 8.0powerpcp5-Shell-Perl-0.004nb4.tgz
NetBSD 8.0x86_64p5-Shell-Perl-0.004nb3.tgz
NetBSD 8.0x86_64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0aarch64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0aarch64p5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0aarch64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0alphap5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0alphap5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0alphap5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0earmv6hfp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0earmv6hfp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0earmv6hfp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0earmv7hfp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0earmv7hfp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0earmv7hfp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0earmv7hfp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0i386p5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0i386p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0mips64ebp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0mips64ebp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0mips64ebp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0mips64ebp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0mips64ebp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0powerpcp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0powerpcp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0powerpcp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0powerpcp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0sparc64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0sparc64p5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0sparc64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0sparcp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0sparcp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0sparcp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0sparcp5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0sparcp5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0x86_64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0x86_64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0x86_64p5-Shell-Perl-0.004nb3.tgz
NetBSD 9.0x86_64p5-Shell-Perl-0.004nb4.tgz
NetBSD 9.0x86_64p5-Shell-Perl-0.004nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.