devel/p5-Path-Class-File-Stat - The NetBSD Packages Collection

Cache and compare stat() calls on a Path::Class::File object

Path::Class::File::Stat is a simple extension of Path::Class::File.
Path::Class::File::Stat is useful in long-running programs (as under
mod_perl) where you might have a file handle opened and want to check
if the underlying file has changed.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Path-Class lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 8.0earmv7hfp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 8.0earmv7hfp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 8.0i386p5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 8.0i386p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 8.0powerpcp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 8.0powerpcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 8.0powerpcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 8.0powerpcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 8.0x86_64p5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 8.0x86_64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0aarch64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0aarch64p5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0aarch64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0alphap5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0alphap5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0alphap5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0earmp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0earmp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0earmp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0earmv6hfp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0earmv6hfp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0earmv6hfp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0earmv7hfp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0earmv7hfp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0earmv7hfp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0earmv7hfp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0i386p5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0i386p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0i386p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0mips64ebp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0mips64ebp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0mips64ebp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0mips64ebp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0mips64ebp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0mipselp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0mipselp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0powerpcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0powerpcp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0powerpcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0powerpcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0sh3elp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0sh3elp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0sh3elp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0sh3elp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0sparc64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0sparc64p5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0sparc64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0sparcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0sparcp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0sparcp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0sparcp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0sparcp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0vaxp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0vaxp5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0vaxp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0vaxp5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0x86_64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0x86_64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0x86_64p5-Path-Class-File-Stat-0.05nb6.tgz
NetBSD 9.0x86_64p5-Path-Class-File-Stat-0.05nb7.tgz
NetBSD 9.0x86_64p5-Path-Class-File-Stat-0.05nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.