devel/p5-Module-ExtractUse - The NetBSD Packages Collection

Perl 5 module to find out what modules are used

Module::ExtractUse is basically a Parse::RecDescent grammar to
parse Perl code. It tries very hard to find all modules (whether
pragmas, Core, or from CPAN) used by the parsed code.

"Usage" is defined by either calling use or require.

Build dependencies

devel/p5-Test-Deep devel/p5-Test-NoWarnings devel/p5-Test-Pod devel/p5-Test-Pod-Coverage devel/p5-UNIVERSAL-require devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

devel/p5-Parse-RecDescent textproc/p5-Pod-Strip lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 8.0earmv7hfp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 8.0earmv7hfp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 8.0i386p5-Module-ExtractUse-0.343nb2.tgz
NetBSD 8.0i386p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 8.0powerpcp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 8.0powerpcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 8.0powerpcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 8.0powerpcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 8.0x86_64p5-Module-ExtractUse-0.343nb2.tgz
NetBSD 8.0x86_64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0aarch64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0aarch64p5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0aarch64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0alphap5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0alphap5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0alphap5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0earmp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0earmp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0earmp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0earmv6hfp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0earmv6hfp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0earmv6hfp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0earmv7hfp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0earmv7hfp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0earmv7hfp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0earmv7hfp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0i386p5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0i386p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0i386p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0mips64ebp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0mips64ebp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0mips64ebp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0mips64ebp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0mips64ebp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0mipselp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0mipselp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0mipselp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0mipselp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0powerpcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0powerpcp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0powerpcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0powerpcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0sh3elp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0sh3elp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0sh3elp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0sh3elp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0sparc64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0sparc64p5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0sparc64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0sparcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0sparcp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0sparcp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0sparcp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0sparcp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0vaxp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0vaxp5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0vaxp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0vaxp5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0x86_64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0x86_64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0x86_64p5-Module-ExtractUse-0.343nb2.tgz
NetBSD 9.0x86_64p5-Module-ExtractUse-0.343nb3.tgz
NetBSD 9.0x86_64p5-Module-ExtractUse-0.343nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.