devel/p5-Eval-LineNumbers - The NetBSD Packages Collection

Add line numbers to heredoc blocks that contain perl source code

Add a "#line "this-file" 392" comment to heredoc/hereis text that is
going to be eval'ed so that error messages will point back to the right
place.

Please note: when you embed "\n" in your code, it gets expanded in
double-quote hereis documents so it will mess up your line numbering.
Use "\\n" instead when you can.

Build dependencies

pkgtools/cwrappers lang/perl5

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 8.0earmv7hfp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 8.0earmv7hfp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 8.0i386p5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 8.0i386p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 8.0powerpcp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 8.0powerpcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 8.0powerpcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 8.0powerpcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 8.0x86_64p5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 8.0x86_64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0aarch64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0aarch64p5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0aarch64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0alphap5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0alphap5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0alphap5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0earmp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0earmp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0earmp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0earmv6hfp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0earmv6hfp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0earmv6hfp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0earmv7hfp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0earmv7hfp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0earmv7hfp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0earmv7hfp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0i386p5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0i386p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0mips64ebp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0mips64ebp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0mips64ebp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0mips64ebp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0mips64ebp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0mipselp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0mipselp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0mipselp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0mipselp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0powerpcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0powerpcp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0powerpcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0powerpcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0sh3elp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0sh3elp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0sh3elp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0sh3elp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0sparc64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0sparc64p5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0sparc64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0sparcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0sparcp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0sparcp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0sparcp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0sparcp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0vaxp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0vaxp5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0vaxp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0vaxp5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0x86_64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0x86_64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0x86_64p5-Eval-LineNumbers-0.1nb4.tgz
NetBSD 9.0x86_64p5-Eval-LineNumbers-0.1nb5.tgz
NetBSD 9.0x86_64p5-Eval-LineNumbers-0.1nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.