devel/ocaml-extlib - The NetBSD Packages Collection

Alternative standard library for OCaml

ExtLib is a project aiming at providing a complete - yet small - standard
library for the OCaml programming langage. The purpose of this library is to
add new functions to OCaml Standard Library modules, to modify some functions
in order to get better performances or more safety (tail-recursive) but also
to provide new modules which should be useful for the average OCaml programmer.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

devel/ocaml-findlib lang/ocaml devel/ocaml-cppo devel/ocaml-findlib devel/ocaml-cppo

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-extlib-1.7.6nb1.tgz
NetBSD 8.0i386ocaml-extlib-1.7.6nb1.tgz
NetBSD 8.0i386ocaml-extlib-1.7.6nb1.tgz
NetBSD 8.0powerpcocaml-extlib-1.7.6nb1.tgz
NetBSD 8.0powerpcocaml-extlib-1.7.6nb1.tgz
NetBSD 8.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 8.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 8.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0aarch64ocaml-extlib-1.7.8.tgz
NetBSD 9.0aarch64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0aarch64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0aarch64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0earmv6hfocaml-extlib-1.7.8.tgz
NetBSD 9.0earmv6hfocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0earmv6hfocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0earmv7hfocaml-extlib-1.7.8.tgz
NetBSD 9.0earmv7hfocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0earmv7hfocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0i386ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0i386ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0i386ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0powerpcocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0x86_64ocaml-extlib-1.7.6nb1.tgz
NetBSD 9.0x86_64ocaml-extlib-1.7.8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.