devel/ocaml-batteries - The NetBSD Packages Collection

Alternative standard library for OCaml

OCaml Batteries included (or simply "Batteries") is a community-driven effort
to standardize a consistent, documented, and comprehensive development
platform for the OCaml programming language.

Build dependencies

devel/ocamlbuild pkgtools/cwrappers devel/ocamlbuild devel/gmake

Runtime dependencies

devel/ocaml-findlib lang/ocaml math/ocaml-num devel/ocaml-findlib math/ocaml-num

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-batteries-2.11.0nb1.tgz
NetBSD 8.0i386ocaml-batteries-2.11.0nb1.tgz
NetBSD 8.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 8.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 8.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 8.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 8.0x86_64ocaml-batteries-2.11.0nb1.tgz
NetBSD 8.0x86_64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0aarch64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0aarch64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0aarch64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0earmv6hfocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0earmv6hfocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0earmv6hfocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0earmv7hfocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0earmv7hfocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0earmv7hfocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0earmv7hfocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0i386ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0i386ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0i386ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0powerpcocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0x86_64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0x86_64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0x86_64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0x86_64ocaml-batteries-2.11.0nb1.tgz
NetBSD 9.0x86_64ocaml-batteries-2.11.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.