devel/lcov - The NetBSD Packages Collection

Front-end for GCC's coverage testing tool gcov

LCOV is a front-end around gcov, the GCC code coverage tool. It
collects the gcov data and creates HTML webpages showing coverage
rates using bar graphs and specific colors.  It can also create
webpages for browsing the source code.

Build dependencies

pkgtools/cwrappers lang/perl5

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflcov-1.13nb4.tgz
NetBSD 8.0earmv7hflcov-1.13nb3.tgz
NetBSD 8.0earmv7hflcov-1.13nb4.tgz
NetBSD 8.0i386lcov-1.13nb3.tgz
NetBSD 8.0i386lcov-1.13nb4.tgz
NetBSD 8.0powerpclcov-1.13nb3.tgz
NetBSD 8.0powerpclcov-1.13nb4.tgz
NetBSD 8.0powerpclcov-1.13nb4.tgz
NetBSD 8.0powerpclcov-1.13nb4.tgz
NetBSD 8.0x86_64lcov-1.13nb3.tgz
NetBSD 8.0x86_64lcov-1.13nb4.tgz
NetBSD 9.0aarch64lcov-1.13nb4.tgz
NetBSD 9.0aarch64lcov-1.13nb3.tgz
NetBSD 9.0aarch64lcov-1.13nb4.tgz
NetBSD 9.0alphalcov-1.13nb4.tgz
NetBSD 9.0alphalcov-1.13nb3.tgz
NetBSD 9.0alphalcov-1.13nb4.tgz
NetBSD 9.0earmlcov-1.13nb3.tgz
NetBSD 9.0earmlcov-1.13nb4.tgz
NetBSD 9.0earmlcov-1.13nb4.tgz
NetBSD 9.0earmv6hflcov-1.13nb4.tgz
NetBSD 9.0earmv6hflcov-1.13nb3.tgz
NetBSD 9.0earmv6hflcov-1.13nb4.tgz
NetBSD 9.0earmv7hflcov-1.13nb4.tgz
NetBSD 9.0earmv7hflcov-1.13nb3.tgz
NetBSD 9.0earmv7hflcov-1.13nb4.tgz
NetBSD 9.0earmv7hflcov-1.13nb4.tgz
NetBSD 9.0i386lcov-1.13nb3.tgz
NetBSD 9.0i386lcov-1.13nb4.tgz
NetBSD 9.0i386lcov-1.13nb4.tgz
NetBSD 9.0mips64eblcov-1.13nb4.tgz
NetBSD 9.0mips64eblcov-1.13nb3.tgz
NetBSD 9.0mips64eblcov-1.13nb3.tgz
NetBSD 9.0mips64eblcov-1.13nb3.tgz
NetBSD 9.0mips64eblcov-1.13nb4.tgz
NetBSD 9.0powerpclcov-1.13nb4.tgz
NetBSD 9.0powerpclcov-1.13nb3.tgz
NetBSD 9.0powerpclcov-1.13nb4.tgz
NetBSD 9.0powerpclcov-1.13nb4.tgz
NetBSD 9.0sparc64lcov-1.13nb4.tgz
NetBSD 9.0sparc64lcov-1.13nb3.tgz
NetBSD 9.0sparc64lcov-1.13nb4.tgz
NetBSD 9.0sparclcov-1.13nb4.tgz
NetBSD 9.0sparclcov-1.13nb3.tgz
NetBSD 9.0sparclcov-1.13nb3.tgz
NetBSD 9.0sparclcov-1.13nb3.tgz
NetBSD 9.0sparclcov-1.13nb4.tgz
NetBSD 9.0x86_64lcov-1.13nb4.tgz
NetBSD 9.0x86_64lcov-1.13nb4.tgz
NetBSD 9.0x86_64lcov-1.13nb3.tgz
NetBSD 9.0x86_64lcov-1.13nb4.tgz
NetBSD 9.0x86_64lcov-1.13nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.