devel/at-spi2-core - The NetBSD Packages Collection

Assistive Technology Service Provider Interface Core

This package provides the core of the Assistive Technology Service
Provider Interface, in particular the registry daemon with which
AT applications such as screen readers can listen for events
broadcast by accessible programs; and also a library, libatspi, to
assist in writing AT applications.  This "version 2" uses DBUS
rather than CORBA for inter-application communication.

Build dependencies

x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/meson devel/pkgconf

Runtime dependencies

devel/glib2 devel/gobject-introspection sysutils/dbus x11/libXi x11/libXtst devel/glib2 devel/gobject-introspection

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfat-spi2-core-2.40.3.tgz
NetBSD 8.0earmv7hfat-spi2-core-2.38.0.tgz
NetBSD 8.0earmv7hfat-spi2-core-2.38.0.tgz
NetBSD 8.0i386at-spi2-core-2.38.0.tgz
NetBSD 8.0i386at-spi2-core-2.38.0.tgz
NetBSD 8.0powerpcat-spi2-core-2.38.0.tgz
NetBSD 8.0powerpcat-spi2-core-2.38.0.tgz
NetBSD 8.0powerpcat-spi2-core-2.38.0.tgz
NetBSD 8.0powerpcat-spi2-core-2.40.3.tgz
NetBSD 8.0x86_64at-spi2-core-2.38.0.tgz
NetBSD 8.0x86_64at-spi2-core-2.38.0.tgz
NetBSD 9.0aarch64at-spi2-core-2.40.3.tgz
NetBSD 9.0aarch64at-spi2-core-2.38.0.tgz
NetBSD 9.0aarch64at-spi2-core-2.38.0.tgz
NetBSD 9.0alphaat-spi2-core-2.40.3.tgz
NetBSD 9.0alphaat-spi2-core-2.38.0.tgz
NetBSD 9.0alphaat-spi2-core-2.38.0.tgz
NetBSD 9.0earmat-spi2-core-2.38.0.tgz
NetBSD 9.0earmat-spi2-core-2.38.0.tgz
NetBSD 9.0earmat-spi2-core-2.40.3.tgz
NetBSD 9.0earmv6hfat-spi2-core-2.40.3.tgz
NetBSD 9.0earmv6hfat-spi2-core-2.38.0.tgz
NetBSD 9.0earmv6hfat-spi2-core-2.38.0.tgz
NetBSD 9.0earmv7hfat-spi2-core-2.40.3.tgz
NetBSD 9.0earmv7hfat-spi2-core-2.38.0.tgz
NetBSD 9.0earmv7hfat-spi2-core-2.38.0.tgz
NetBSD 9.0earmv7hfat-spi2-core-2.40.3.tgz
NetBSD 9.0i386at-spi2-core-2.38.0.tgz
NetBSD 9.0i386at-spi2-core-2.38.0.tgz
NetBSD 9.0m68kat-spi2-core-2.36.0.tgz
NetBSD 9.0m68kat-spi2-core-2.38.0.tgz
NetBSD 9.0m68kat-spi2-core-2.40.3.tgz
NetBSD 9.0mips64ebat-spi2-core-2.38.0.tgz
NetBSD 9.0mips64ebat-spi2-core-2.36.0.tgz
NetBSD 9.0mips64ebat-spi2-core-2.38.0.tgz
NetBSD 9.0mips64ebat-spi2-core-2.38.0.tgz
NetBSD 9.0mips64ebat-spi2-core-2.40.3.tgz
NetBSD 9.0mipselat-spi2-core-2.38.0.tgz
NetBSD 9.0mipselat-spi2-core-2.38.0.tgz
NetBSD 9.0mipselat-spi2-core-2.38.0.tgz
NetBSD 9.0mipselat-spi2-core-2.40.3.tgz
NetBSD 9.0powerpcat-spi2-core-2.38.0.tgz
NetBSD 9.0powerpcat-spi2-core-2.38.0.tgz
NetBSD 9.0powerpcat-spi2-core-2.38.0.tgz
NetBSD 9.0powerpcat-spi2-core-2.40.3.tgz
NetBSD 9.0sh3elat-spi2-core-2.38.0.tgz
NetBSD 9.0sh3elat-spi2-core-2.36.0.tgz
NetBSD 9.0sh3elat-spi2-core-2.38.0.tgz
NetBSD 9.0sh3elat-spi2-core-2.38.0.tgz
NetBSD 9.0sh3elat-spi2-core-2.40.3.tgz
NetBSD 9.0sparc64at-spi2-core-2.38.0.tgz
NetBSD 9.0sparc64at-spi2-core-2.38.0.tgz
NetBSD 9.0sparc64at-spi2-core-2.40.3.tgz
NetBSD 9.0sparcat-spi2-core-2.38.0.tgz
NetBSD 9.0sparcat-spi2-core-2.36.0.tgz
NetBSD 9.0sparcat-spi2-core-2.38.0.tgz
NetBSD 9.0sparcat-spi2-core-2.38.0.tgz
NetBSD 9.0sparcat-spi2-core-2.40.3.tgz
NetBSD 9.0x86_64at-spi2-core-2.38.0.tgz
NetBSD 9.0x86_64at-spi2-core-2.40.3.tgz
NetBSD 9.0x86_64at-spi2-core-2.38.0.tgz
NetBSD 9.0x86_64at-spi2-core-2.38.0.tgz
NetBSD 9.0x86_64at-spi2-core-2.40.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.