databases/py-agate-excel - The NetBSD Packages Collection

EXCEL read/write support to agate

agate-excel adds read support for Excel files (xls and xlsx) to agate.

Important links:
    agate https://agate.rtfd.org
    Documentation: https://agate-excel.rtfd.org
    Repository: https://github.com/wireservice/agate-excel
    Issues: https://github.com/wireservice/agate-excel/issues

Build dependencies

devel/py-setuptools devel/py-wheel devel/py-build misc/py-installer pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/py-agate devel/py-olefile textproc/py-openpyxl textproc/py-xlrd lang/python311 lang/python311

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64py310-agate-excel-0.4.1.tgz
NetBSD 10.0aarch64py311-agate-excel-0.4.1.tgz
NetBSD 10.0aarch64py312-agate-excel-0.4.1.tgz
NetBSD 10.0aarch64py38-agate-excel-0.4.1.tgz
NetBSD 10.0aarch64py39-agate-excel-0.4.1.tgz
NetBSD 10.0earmv6hfpy310-agate-excel-0.4.1.tgz
NetBSD 10.0earmv6hfpy311-agate-excel-0.4.1.tgz
NetBSD 10.0earmv6hfpy312-agate-excel-0.4.1.tgz
NetBSD 10.0earmv6hfpy38-agate-excel-0.4.1.tgz
NetBSD 10.0earmv6hfpy39-agate-excel-0.4.1.tgz
NetBSD 10.0earmv7hfpy310-agate-excel-0.4.1.tgz
NetBSD 10.0earmv7hfpy311-agate-excel-0.4.1.tgz
NetBSD 10.0earmv7hfpy312-agate-excel-0.4.1.tgz
NetBSD 10.0earmv7hfpy38-agate-excel-0.4.1.tgz
NetBSD 10.0earmv7hfpy39-agate-excel-0.4.1.tgz
NetBSD 10.0i386py310-agate-excel-0.4.1.tgz
NetBSD 10.0i386py311-agate-excel-0.4.1.tgz
NetBSD 10.0i386py312-agate-excel-0.4.1.tgz
NetBSD 10.0i386py38-agate-excel-0.4.1.tgz
NetBSD 10.0i386py39-agate-excel-0.4.1.tgz
NetBSD 10.0x86_64py310-agate-excel-0.4.1.tgz
NetBSD 10.0x86_64py311-agate-excel-0.4.1.tgz
NetBSD 10.0x86_64py312-agate-excel-0.4.1.tgz
NetBSD 10.0x86_64py38-agate-excel-0.4.1.tgz
NetBSD 10.0x86_64py39-agate-excel-0.4.1.tgz
NetBSD 9.0aarch64py310-agate-excel-0.4.1.tgz
NetBSD 9.0aarch64py311-agate-excel-0.4.1.tgz
NetBSD 9.0aarch64py312-agate-excel-0.4.1.tgz
NetBSD 9.0aarch64py38-agate-excel-0.4.1.tgz
NetBSD 9.0aarch64py39-agate-excel-0.4.1.tgz
NetBSD 9.0earmv6hfpy310-agate-excel-0.4.1.tgz
NetBSD 9.0earmv6hfpy311-agate-excel-0.4.1.tgz
NetBSD 9.0earmv6hfpy38-agate-excel-0.4.1.tgz
NetBSD 9.0earmv6hfpy39-agate-excel-0.4.1.tgz
NetBSD 9.0earmv7hfpy310-agate-excel-0.4.1.tgz
NetBSD 9.0earmv7hfpy311-agate-excel-0.4.1.tgz
NetBSD 9.0earmv7hfpy38-agate-excel-0.4.1.tgz
NetBSD 9.0earmv7hfpy39-agate-excel-0.4.1.tgz
NetBSD 9.0i386py310-agate-excel-0.4.1.tgz
NetBSD 9.0i386py311-agate-excel-0.4.1.tgz
NetBSD 9.0i386py312-agate-excel-0.4.1.tgz
NetBSD 9.0i386py38-agate-excel-0.4.1.tgz
NetBSD 9.0i386py39-agate-excel-0.4.1.tgz
NetBSD 9.0x86_64py310-agate-excel-0.4.1.tgz
NetBSD 9.0x86_64py311-agate-excel-0.4.1.tgz
NetBSD 9.0x86_64py312-agate-excel-0.4.1.tgz
NetBSD 9.0x86_64py38-agate-excel-0.4.1.tgz
NetBSD 9.0x86_64py39-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py310-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py311-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py312-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py38-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py39-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py310-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py311-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py312-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py38-agate-excel-0.4.1.tgz
NetBSD 9.3x86_64py39-agate-excel-0.4.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.