converters/hs-pandoc-lua-engine - The NetBSD Packages Collection

Lua engine to power custom pandoc conversions

This package provides a pandoc scripting engine based on Lua. It allows to
write filters, custom readers, and custom writers in Lua.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

converters/hs-aeson textproc/hs-citeproc devel/hs-data-default textproc/hs-pandoc-types textproc/hs-doclayout textproc/hs-doctemplates lang/hs-hslua textproc/hs-hslua-module-doclayout sysutils/hs-hslua-module-path devel/hs-hslua-module-system textproc/hs-hslua-module-text devel/hs-hslua-module-version archivers/hs-hslua-module-zip lang/hs-hslua-repl devel/hs-lpeg converters/hs-pandoc-base security/hs-SHA devel/hs-pandoc-lua-marshal lang/ghc96 converters/hs-aeson textproc/hs-citeproc devel/hs-data-default textproc/hs-pandoc-types textproc/hs-doclayout textproc/hs-doctemplates lang/hs-hslua textproc/hs-hslua-module-doclayout sysutils/hs-hslua-module-path devel/hs-hslua-module-system textproc/hs-hslua-module-text devel/hs-hslua-module-version archivers/hs-hslua-module-zip lang/hs-hslua-repl devel/hs-lpeg converters/hs-pandoc-base security/hs-SHA devel/hs-pandoc-lua-marshal

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64hs-pandoc-lua-engine-0.2.1.2nb1.tgz
NetBSD 10.0aarch64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 10.0aarch64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 10.0x86_64hs-pandoc-lua-engine-0.2.1.2nb1.tgz
NetBSD 10.0_BETAx86_64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 8.0x86_64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 8.0x86_64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 9.0aarch64hs-pandoc-lua-engine-0.2.1.2nb1.tgz
NetBSD 9.0aarch64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 9.0aarch64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 9.0x86_64hs-pandoc-lua-engine-0.2.1.2nb1.tgz
NetBSD 9.0x86_64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 9.3x86_64hs-pandoc-lua-engine-0.1nb1.tgz
NetBSD 9.3x86_64hs-pandoc-lua-engine-0.2.1.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.