biology/gromacs - The NetBSD Packages Collection

Molecular dynamics package

GROMACS is a versatile package to perform molecular dynamics,
i.e. simulate the Newtonian equations of motion for systems with
hundreds to millions of particles.

It is primarily designed for biochemical molecules like proteins,
lipids and nucleic acids that have a lot of complicated bonded
interactions, but since GROMACS is extremely fast at calculating
the nonbonded interactions (that usually dominate simulations)
many groups are also using it for research on non-biological
systems, e.g. polymers.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

lang/perl5 parallel/mpi-ch math/fftw math/gsl textproc/libxml2 math/fftw math/gsl textproc/libxml2

Available binary packages

aarch64:gromacs-4.5.5nb9.tgz(NetBSD 9.0)
aarch64:gromacs-4.5.5nb10.tgz(NetBSD 9.0)
aarch64:gromacs-4.5.5nb11.tgz(NetBSD 9.0)
i386:gromacs-4.5.5nb9.tgz(NetBSD 8.0)
i386:gromacs-4.5.5nb10.tgz(NetBSD 8.0)
i386:gromacs-4.5.5nb11.tgz(NetBSD 8.0)
i386:gromacs-4.5.5nb9.tgz(NetBSD 9.0)
i386:gromacs-4.5.5nb10.tgz(NetBSD 9.0)
i386:gromacs-4.5.5nb11.tgz(NetBSD 9.0)
powerpc:gromacs-4.5.5nb9.tgz(NetBSD 8.0)
powerpc:gromacs-4.5.5nb11.tgz(NetBSD 8.0)
powerpc:gromacs-4.5.5nb10.tgz(NetBSD 8.0)
powerpc:gromacs-4.5.5nb10.tgz(NetBSD 9.0)
powerpc:gromacs-4.5.5nb9.tgz(NetBSD 9.0)
sparc64:gromacs-4.5.5nb11.tgz(NetBSD 9.0)
sparc64:gromacs-4.5.5nb10.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb11.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb11.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb11.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb10.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb10.tgz(NetBSD 8.0)
x86_64:gromacs-4.5.5nb9.tgz(NetBSD 8.0)
x86_64:gromacs-4.5.5nb11.tgz(NetBSD 8.0)
x86_64:gromacs-4.5.5nb9.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb10.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb11.tgz(NetBSD 9.0)
x86_64:gromacs-4.5.5nb11.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

mpi
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]