audio/lame - The NetBSD Packages Collection

Fast, high quality MP3 encoder

Following the great history of GNU naming, LAME originally stood for
LAME Ain't an Mp3 Encoder. LAME started life as a GPL'd patch against
the dist10 ISO demonstration source, and thus was incapable of
producing an mp3 stream or even being compiled by itself. But in May
2000, the last remnants of the ISO source code were replaced, and now
LAME is the source code for a fully GPL'd MP3 encoder, with speed and
quality to rival all commercial competitors.

LAME is an educational tool to be used for learning about MP3
encoding. The goal of the LAME project is to use the open source model
to improve the psycho acoustics, noise shaping and speed of
MP3. Another goal of the LAME project is to use these improvements for
the basis of a patent free audio compression codec for the GNU
project.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflame-3.100nb2.tgz
NetBSD 8.0earmv7hflame-3.100nb2.tgz
NetBSD 8.0earmv7hflame-3.100nb2.tgz
NetBSD 8.0earmv7hflame-3.100nb2.tgz
NetBSD 8.0i386lame-3.100nb2.tgz
NetBSD 8.0i386lame-3.100nb2.tgz
NetBSD 8.0i386lame-3.100nb2.tgz
NetBSD 8.0i386lame-3.100nb2.tgz
NetBSD 8.0powerpclame-3.100nb2.tgz
NetBSD 8.0powerpclame-3.100nb2.tgz
NetBSD 8.0powerpclame-3.100nb2.tgz
NetBSD 8.0powerpclame-3.100nb2.tgz
NetBSD 8.0powerpclame-3.100nb2.tgz
NetBSD 8.0x86_64lame-3.100nb2.tgz
NetBSD 8.0x86_64lame-3.100nb2.tgz
NetBSD 8.0x86_64lame-3.100nb2.tgz
NetBSD 8.0x86_64lame-3.100nb2.tgz
NetBSD 9.0aarch64lame-3.100nb2.tgz
NetBSD 9.0aarch64lame-3.100nb2.tgz
NetBSD 9.0aarch64lame-3.100nb2.tgz
NetBSD 9.0aarch64lame-3.100nb2.tgz
NetBSD 9.0aarch64lame-3.100nb2.tgz
NetBSD 9.0alphalame-3.100nb2.tgz
NetBSD 9.0alphalame-3.100nb2.tgz
NetBSD 9.0alphalame-3.100nb2.tgz
NetBSD 9.0earmlame-3.100nb2.tgz
NetBSD 9.0earmlame-3.100nb2.tgz
NetBSD 9.0earmlame-3.100nb2.tgz
NetBSD 9.0earmv6hflame-3.100nb2.tgz
NetBSD 9.0earmv6hflame-3.100nb2.tgz
NetBSD 9.0earmv6hflame-3.100nb2.tgz
NetBSD 9.0earmv6hflame-3.100nb2.tgz
NetBSD 9.0earmv6hflame-3.100nb2.tgz
NetBSD 9.0earmv6hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0earmv7hflame-3.100nb2.tgz
NetBSD 9.0i386lame-3.100nb2.tgz
NetBSD 9.0i386lame-3.100nb2.tgz
NetBSD 9.0i386lame-3.100nb2.tgz
NetBSD 9.0i386lame-3.100nb2.tgz
NetBSD 9.0m68klame-3.100nb2.tgz
NetBSD 9.0m68klame-3.100nb2.tgz
NetBSD 9.0m68klame-3.100nb2.tgz
NetBSD 9.0m68klame-3.100nb2.tgz
NetBSD 9.0mips64eblame-3.100nb2.tgz
NetBSD 9.0mips64eblame-3.100nb2.tgz
NetBSD 9.0mips64eblame-3.100nb2.tgz
NetBSD 9.0mips64eblame-3.100nb2.tgz
NetBSD 9.0mips64eblame-3.100nb2.tgz
NetBSD 9.0mipsellame-3.100nb2.tgz
NetBSD 9.0mipsellame-3.100nb2.tgz
NetBSD 9.0mipsellame-3.100nb2.tgz
NetBSD 9.0mipsellame-3.100nb2.tgz
NetBSD 9.0powerpclame-3.100nb2.tgz
NetBSD 9.0powerpclame-3.100nb2.tgz
NetBSD 9.0powerpclame-3.100nb2.tgz
NetBSD 9.0powerpclame-3.100nb2.tgz
NetBSD 9.0powerpclame-3.100nb2.tgz
NetBSD 9.0sh3ellame-3.100nb2.tgz
NetBSD 9.0sh3ellame-3.100nb2.tgz
NetBSD 9.0sh3ellame-3.100nb2.tgz
NetBSD 9.0sh3ellame-3.100nb2.tgz
NetBSD 9.0sh3ellame-3.100nb2.tgz
NetBSD 9.0sparc64lame-3.100nb2.tgz
NetBSD 9.0sparc64lame-3.100nb2.tgz
NetBSD 9.0sparc64lame-3.100nb2.tgz
NetBSD 9.0sparclame-3.100nb2.tgz
NetBSD 9.0sparclame-3.100nb2.tgz
NetBSD 9.0sparclame-3.100nb2.tgz
NetBSD 9.0sparclame-3.100nb2.tgz
NetBSD 9.0sparclame-3.100nb2.tgz
NetBSD 9.0vaxlame-3.100nb2.tgz
NetBSD 9.0vaxlame-3.100nb2.tgz
NetBSD 9.0vaxlame-3.100nb2.tgz
NetBSD 9.0vaxlame-3.100nb2.tgz
NetBSD 9.0x86_64lame-3.100nb2.tgz
NetBSD 9.0x86_64lame-3.100nb2.tgz
NetBSD 9.0x86_64lame-3.100nb2.tgz
NetBSD 9.0x86_64lame-3.100nb2.tgz
NetBSD 9.0x86_64lame-3.100nb2.tgz
NetBSD 9.0x86_64lame-3.100nb2.tgz
NetBSD 9.0x86_64lame-3.100nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gtk
Enable support for GTK.
sndfile
Enable sndfile support.
unicode
Enable support for Unicode.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.