archivers/karchive - The NetBSD Packages Collection

Qt 5 addon providing access to numerous types of archives

KArchive provides classes for easy reading, creation and manipulation of
"archive" formats like ZIP and TAR.

It also provides transparent compression and decompression of data, like the
GZip format, via a subclass of QIODevice.

Build dependencies

devel/extra-cmake-modules devel/extra-cmake-modules pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/cmake

Runtime dependencies

x11/qt5-qtbase x11/qt5-qtbase

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfkarchive-5.80.0nb1.tgz
NetBSD 8.0earmv7hfkarchive-5.70.0nb2.tgz
NetBSD 8.0earmv7hfkarchive-5.80.0nb1.tgz
NetBSD 8.0i386karchive-5.70.0nb2.tgz
NetBSD 8.0i386karchive-5.80.0nb1.tgz
NetBSD 8.0powerpckarchive-5.70.0nb2.tgz
NetBSD 8.0powerpckarchive-5.80.0nb1.tgz
NetBSD 8.0powerpckarchive-5.80.0nb1.tgz
NetBSD 8.0powerpckarchive-5.80.0nb1.tgz
NetBSD 8.0x86_64karchive-5.70.0nb2.tgz
NetBSD 8.0x86_64karchive-5.80.0nb1.tgz
NetBSD 9.0aarch64karchive-5.80.0nb1.tgz
NetBSD 9.0aarch64karchive-5.70.0nb2.tgz
NetBSD 9.0aarch64karchive-5.80.0nb1.tgz
NetBSD 9.0alphakarchive-5.80.0nb1.tgz
NetBSD 9.0alphakarchive-5.70.0nb2.tgz
NetBSD 9.0alphakarchive-5.80.0nb1.tgz
NetBSD 9.0earmkarchive-5.70.0nb2.tgz
NetBSD 9.0earmkarchive-5.80.0nb1.tgz
NetBSD 9.0earmkarchive-5.80.0nb1.tgz
NetBSD 9.0earmv6hfkarchive-5.80.0nb1.tgz
NetBSD 9.0earmv6hfkarchive-5.70.0nb2.tgz
NetBSD 9.0earmv6hfkarchive-5.80.0nb1.tgz
NetBSD 9.0earmv7hfkarchive-5.80.0nb1.tgz
NetBSD 9.0earmv7hfkarchive-5.70.0nb2.tgz
NetBSD 9.0earmv7hfkarchive-5.80.0nb1.tgz
NetBSD 9.0i386karchive-5.70.0nb2.tgz
NetBSD 9.0i386karchive-5.80.0nb1.tgz
NetBSD 9.0i386karchive-5.80.0nb1.tgz
NetBSD 9.0m68kkarchive-5.70.0nb1.tgz
NetBSD 9.0m68kkarchive-5.70.0nb2.tgz
NetBSD 9.0m68kkarchive-5.80.0nb1.tgz
NetBSD 9.0mips64ebkarchive-5.80.0nb1.tgz
NetBSD 9.0mips64ebkarchive-5.70.0nb1.tgz
NetBSD 9.0mips64ebkarchive-5.70.0nb2.tgz
NetBSD 9.0mips64ebkarchive-5.70.0nb2.tgz
NetBSD 9.0mips64ebkarchive-5.80.0nb1.tgz
NetBSD 9.0powerpckarchive-5.80.0nb1.tgz
NetBSD 9.0powerpckarchive-5.70.0nb2.tgz
NetBSD 9.0powerpckarchive-5.80.0nb1.tgz
NetBSD 9.0powerpckarchive-5.80.0nb1.tgz
NetBSD 9.0sparc64karchive-5.80.0nb1.tgz
NetBSD 9.0sparc64karchive-5.70.0nb2.tgz
NetBSD 9.0sparc64karchive-5.80.0nb1.tgz
NetBSD 9.0x86_64karchive-5.80.0nb1.tgz
NetBSD 9.0x86_64karchive-5.80.0nb1.tgz
NetBSD 9.0x86_64karchive-5.70.0nb2.tgz
NetBSD 9.0x86_64karchive-5.80.0nb1.tgz
NetBSD 9.0x86_64karchive-5.80.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.