www/ruby-websocket-driver - The NetBSD Packages Collection

WebSocket protocol handler with pluggable I/O

Websocket-driver module provides a complete implementation of
the WebSocket protocols that can be hooked up to any TCP library.
It aims to simplify things by decoupling the protocol details
from the I/O layer, such that users only need to implement code
to stream data in and out of it without needing to know anything
about how the protocol actually works. Think of it as a complete
WebSocket system with pluggable I/O.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

www/ruby-websocket-extensions lang/ruby26-base

Available binary packages

aarch64:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
aarch64:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
aarch64:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
aarch64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
aarch64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
aarch64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
aarch64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
aarch64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
aarch64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
alpha:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
alpha:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
alpha:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
alpha:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
alpha:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
alpha:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
alpha:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
alpha:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
alpha:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earm:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earm:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earm:ruby24-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earm:ruby25-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earm:ruby26-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earm:ruby27-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earmv6hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
earmv6hf:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
earmv6hf:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
earmv6hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv6hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
earmv7hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
earmv7hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
earmv7hf:ruby24-websocket-driver-0.7.1.tgz(NetBSD 8.0)
earmv7hf:ruby25-websocket-driver-0.7.1.tgz(NetBSD 8.0)
earmv7hf:ruby26-websocket-driver-0.7.1.tgz(NetBSD 8.0)
earmv7hf:ruby27-websocket-driver-0.7.1.tgz(NetBSD 8.0)
earmv7hf:ruby25-websocket-driver-0.7.2.tgz(NetBSD 8.0)
earmv7hf:ruby26-websocket-driver-0.7.2.tgz(NetBSD 8.0)
earmv7hf:ruby27-websocket-driver-0.7.2.tgz(NetBSD 8.0)
earmv7hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
earmv7hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
earmv7hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
earmv7hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby24-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earmv7hf:ruby25-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earmv7hf:ruby26-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earmv7hf:ruby27-websocket-driver-0.7.1.tgz(NetBSD 9.0)
earmv7hf:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
earmv7hf:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
earmv7hf:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
earmv7hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
earmv7hf:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
i386:ruby25-websocket-driver-0.7.2.tgz(NetBSD 8.0)
i386:ruby26-websocket-driver-0.7.2.tgz(NetBSD 8.0)
i386:ruby27-websocket-driver-0.7.2.tgz(NetBSD 8.0)
i386:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
i386:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
i386:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
i386:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
i386:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
i386:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
i386:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
i386:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
i386:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
i386:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
i386:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
i386:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
i386:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
i386:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
i386:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
m68k:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
mips64eb:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
mips64eb:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
mips64eb:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
mips64eb:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
mips64eb:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
mips64eb:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
mipsel:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
powerpc:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
powerpc:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
powerpc:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
powerpc:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
powerpc:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
powerpc:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
powerpc:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
powerpc:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
powerpc:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
powerpc:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
powerpc:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
powerpc:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
sparc64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
sparc64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
sparc64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
sparc64:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
sparc64:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
sparc64:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
sparc64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
sparc64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
sparc64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
sparc:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
sparc:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
sparc:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
x86_64:ruby25-websocket-driver-0.7.2.tgz(NetBSD 8.0)
x86_64:ruby26-websocket-driver-0.7.2.tgz(NetBSD 8.0)
x86_64:ruby27-websocket-driver-0.7.2.tgz(NetBSD 8.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 8.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 8.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 8.0)
x86_64:ruby25-websocket-driver-0.7.2.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.2.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.2.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby25-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby26-websocket-driver-0.7.3.tgz(NetBSD 9.0)
x86_64:ruby27-websocket-driver-0.7.3.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]