www/p5-Mojolicious - The NetBSD Packages Collection

Perl web framework: The Web In A Box!

Back in the early days of the web there was this wonderful Perl
library called CGI, many people only learned Perl because of it.
It was simple enough to get started without knowing much about the
language and powerful enough to keep you going, learning by doing
was much fun. While most of the techniques used are outdated now,
the idea behind it is not. Mojolicious is a new attempt at implementing
this idea using state of the art technology. Features:

    * An amazing MVC web framework supporting a simplified single
    file mode through Mojolicious::Lite.  Powerful out of the box
    with RESTful routes, plugins, Perl-ish templates, session
    management, signed cookies, testing framework, static file
    server, I18N, first class unicode support and much more for
    you to discover.
    * Very clean, portable and Object Oriented pure Perl API without
    any hidden magic and no requirements besides Perl 5.8.7.
    * Full stack HTTP 1.1 and WebSocket client/server implementation
    with IPv6, TLS, Bonjour, IDNA, Comet (long polling), chunking
    and multipart support.
    * Builtin async IO web server supporting epoll, kqueue, UNIX
    domain sockets and hot deployment, perfect for embedding.
    * Automatic CGI, FastCGI and PSGI detection.
    * JSON and XML/HTML5 parser with CSS3 selector support.
    * Fresh code based upon years of experience developing Catalyst.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Available binary packages

aarch64:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
aarch64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
aarch64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
alpha:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
alpha:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
alpha:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
earm:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
earm:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
earmv6hf:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
earmv6hf:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
earmv6hf:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
earmv6hf:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
earmv7hf:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
earmv7hf:p5-Mojolicious-7.94nb1.tgz(NetBSD 8.0)
earmv7hf:p5-Mojolicious-7.94nb1.tgz(NetBSD 8.0)
earmv7hf:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
earmv7hf:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
earmv7hf:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
earmv7hf:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
earmv7hf:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
earmv7hf:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
i386:p5-Mojolicious-7.94nb1.tgz(NetBSD 8.0)
i386:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
i386:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
i386:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
i386:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
i386:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
m68k:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
mips64eb:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
mips64eb:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
mipsel:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
powerpc:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
powerpc:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
powerpc:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
powerpc:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
powerpc:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
sh3el:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
sparc64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
sparc64:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
sparc64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
sparc:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
sparc:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
sparc:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
x86_64:p5-Mojolicious-7.94nb1.tgz(NetBSD 8.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 8.0)
x86_64:p5-Mojolicious-7.94nb1.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)
x86_64:p5-Mojolicious-8.59.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]