www/p5-HTML-FormFu - The NetBSD Packages Collection

HTML Form Creation, Rendering and Validation Framework

HTML::FormFu is a HTML form framework which aims to be as easy as possible
to use for basic web forms, but with the power and flexibility to do
anything else you might want to do (as long as it involves forms).

Almost any part of formfu's behaviour and output can be configured. By
default formfu renders "XHTML 1.0 Strict" compliant markup, with as
little extra markup as possible, but with sufficient CSS class names to
allow for a wide-range of output styles to be generated by changing only
the CSS.

Build dependencies

devel/p5-Test-NoWarnings pkgtools/cwrappers

Runtime dependencies

www/p5-Captcha-reCAPTCHA devel/p5-Class-Accessor-Chained devel/p5-Clone devel/p5-Config-Any security/p5-Crypt-CBC security/p5-Crypt-DES devel/p5-Data-Visitor devel/p5-Date-Calc time/p5-DateTime time/p5-DateTime-Format-Builder time/p5-DateTime-Format-Natural time/p5-DateTime-Format-Strptime time/p5-DateTime-Locale mail/p5-Email-Valid devel/p5-File-ShareDir devel/p5-File-ShareDir-Install www/p5-HTML-Scrubber www/p5-HTML-TokeParser-Simple devel/p5-Hash-Flatten devel/p5-List-MoreUtils devel/p5-Module-Pluggable devel/p5-Moose devel/p5-MooseX-Attribute-Chained devel/p5-MooseX-Aliases devel/p5-MooseX-SetOnce textproc/p5-Number-Format devel/p5-Path-Class devel/p5-Readonly textproc/p5-Regexp-Common devel/p5-Task-Weaken www/p5-Template-Toolkit textproc/p5-YAML-LibYAML www/p5-libwww lang/perl5 lang/perl5

Available binary packages

aarch64:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
aarch64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
aarch64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
alpha:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
alpha:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
alpha:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
earm:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
earm:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
earmv6hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
earmv7hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
earmv7hf:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
i386:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 8.0)
i386:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
i386:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
i386:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
i386:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
i386:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
mips64eb:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
mips64eb:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
powerpc:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
powerpc:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
powerpc:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
powerpc:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
sparc64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
sparc64:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
sparc64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
sparc:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
sparc:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
x86_64:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 8.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 8.0)
x86_64:p5-HTML-FormFu-2.07nb1.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)
x86_64:p5-HTML-FormFu-2.07nb2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]