www/p5-Catalyst-Controller-BindLex - The NetBSD Packages Collection

Put lexicals on the catalyst stash

This plugin lets you put your lexicals on the stash and elsewhere
very easily.

It uses some funky modules to get it's job done: PadWalker,
Array::RefElem, Devel::Caller, Devel::LexAlias and attributes. In
some people's opinion this hurts this plugin's reputation ;-).

If you use the same name for two variables with the same storage
binding attribute they will be aliased to each other, so you can
use this for reading as well as writing values across controller
subs. This is almost like sharing your lexical scope.

sub bar : Local {
    my ( $self, $c ) = @_;

    my $x : Stashed;
    my %y : Stashed;

    $x = 100;

    do_something( $c->stash->{x} );    # 100

    $c->forward("gorch");
}

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Array-RefElem www/p5-Catalyst-Runtime devel/p5-Devel-Caller devel/p5-Devel-LexAlias devel/p5-PadWalker lang/perl5 lang/perl5

Available binary packages

aarch64:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 9.0)
aarch64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
aarch64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
alpha:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
alpha:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
earmv6hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
earmv6hf:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 9.0)
earmv6hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
earmv6hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 8.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 8.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 9.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 9.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
earmv7hf:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
i386:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 8.0)
i386:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
i386:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
i386:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 9.0)
i386:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
i386:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
mips64eb:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
powerpc:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
powerpc:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
powerpc:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
powerpc:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 9.0)
sparc64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
sparc64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 8.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 8.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb13.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)
x86_64:p5-Catalyst-Controller-BindLex-0.05nb15.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]