www/lua-http - The NetBSD Packages Collection

HTTP/1.0/1.1/2.0 client and server library for Lua

A HTTP library for Lua.

## Features

- Optionally asynchronous (including DNS lookups and TLS)
- Supports HTTP(S) version 1.0, 1.1 and 2
- Functionality for both client and server
- Cookie Management
- Websockets

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/lua-basexx devel/lua-binaryheap devel/lua-cqueues devel/lua-fifo devel/lua-lpeg devel/lua-lpeg-patterns security/lua-ossl www/lua-psl archivers/lua-zlib lang/lua53

Available binary packages

aarch64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
aarch64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
aarch64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
aarch64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
aarch64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
aarch64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
aarch64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
aarch64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua51-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua52-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua53-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua54-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua51-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua52-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua53-http-0.3nb1.tgz(NetBSD 9.0)
alpha:lua54-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua51-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua52-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua53-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua54-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua51-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua52-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua53-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua54-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua51-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua52-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua53-http-0.3nb1.tgz(NetBSD 9.0)
earmv6hf:lua54-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua51-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua52-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua53-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua54-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua51-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua52-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua53-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua54-http-0.3nb1.tgz(NetBSD 8.0)
earmv7hf:lua51-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua52-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua53-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua54-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua51-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua52-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua53-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua54-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua51-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua52-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua53-http-0.3nb1.tgz(NetBSD 9.0)
earmv7hf:lua54-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua51-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua52-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua53-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua54-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua51-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua52-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua53-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua54-http-0.3nb1.tgz(NetBSD 8.0)
i386:lua51-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua52-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua53-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua54-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua51-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua52-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua53-http-0.3nb1.tgz(NetBSD 9.0)
i386:lua54-http-0.3nb1.tgz(NetBSD 9.0)
mips64eb:lua51-http-0.3nb1.tgz(NetBSD 9.0)
mips64eb:lua52-http-0.3nb1.tgz(NetBSD 9.0)
mips64eb:lua53-http-0.3nb1.tgz(NetBSD 9.0)
mips64eb:lua54-http-0.3nb1.tgz(NetBSD 9.0)
powerpc:lua51-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua52-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua53-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua54-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua51-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua52-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua53-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua54-http-0.3nb1.tgz(NetBSD 8.0)
powerpc:lua51-http-0.3nb1.tgz(NetBSD 9.0)
powerpc:lua52-http-0.3nb1.tgz(NetBSD 9.0)
powerpc:lua53-http-0.3nb1.tgz(NetBSD 9.0)
powerpc:lua54-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
sparc64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 8.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua51-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua52-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua53-http-0.3nb1.tgz(NetBSD 9.0)
x86_64:lua54-http-0.3nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]