sysutils/py-reprotest - The NetBSD Packages Collection

Build packages and check them for reproducibility

reprotest builds the same source code twice in different environments, and then
checks the binaries produced by each build for differences. If any are found,
then diffoscope(1) (or if unavailable then diff(1)) is used to display them in
detail for later analysis.

Build dependencies

devel/py-setuptools pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

sysutils/py-diffoscope devel/py-distro devel/py-rstr lang/python310 lang/python310

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64py310-reprotest-0.7.22.tgz
NetBSD 10.0aarch64py311-reprotest-0.7.22.tgz
NetBSD 10.0aarch64py38-reprotest-0.7.22.tgz
NetBSD 10.0aarch64py39-reprotest-0.7.22.tgz
NetBSD 10.0earmv6hfpy310-reprotest-0.7.22.tgz
NetBSD 10.0earmv6hfpy311-reprotest-0.7.22.tgz
NetBSD 10.0earmv6hfpy38-reprotest-0.7.22.tgz
NetBSD 10.0earmv6hfpy39-reprotest-0.7.22.tgz
NetBSD 10.0earmv7hfpy310-reprotest-0.7.22.tgz
NetBSD 10.0earmv7hfpy311-reprotest-0.7.22.tgz
NetBSD 10.0earmv7hfpy38-reprotest-0.7.22.tgz
NetBSD 10.0earmv7hfpy39-reprotest-0.7.22.tgz
NetBSD 10.0x86_64py310-reprotest-0.7.22.tgz
NetBSD 10.0x86_64py311-reprotest-0.7.22.tgz
NetBSD 10.0x86_64py38-reprotest-0.7.22.tgz
NetBSD 10.0x86_64py39-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy310-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy311-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy38-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy39-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy310-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy311-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy38-reprotest-0.7.22.tgz
NetBSD 8.0powerpcpy39-reprotest-0.7.22.tgz
NetBSD 9.0aarch64py310-reprotest-0.7.22.tgz
NetBSD 9.0aarch64py311-reprotest-0.7.22.tgz
NetBSD 9.0aarch64py38-reprotest-0.7.22.tgz
NetBSD 9.0aarch64py39-reprotest-0.7.22.tgz
NetBSD 9.0alphapy310-reprotest-0.7.22.tgz
NetBSD 9.0alphapy311-reprotest-0.7.22.tgz
NetBSD 9.0alphapy38-reprotest-0.7.22.tgz
NetBSD 9.0alphapy39-reprotest-0.7.22.tgz
NetBSD 9.0earmv6hfpy310-reprotest-0.7.22.tgz
NetBSD 9.0earmv6hfpy311-reprotest-0.7.22.tgz
NetBSD 9.0earmv6hfpy38-reprotest-0.7.22.tgz
NetBSD 9.0earmv6hfpy39-reprotest-0.7.22.tgz
NetBSD 9.0earmv7hfpy310-reprotest-0.7.22.tgz
NetBSD 9.0earmv7hfpy311-reprotest-0.7.22.tgz
NetBSD 9.0earmv7hfpy38-reprotest-0.7.22.tgz
NetBSD 9.0earmv7hfpy39-reprotest-0.7.22.tgz
NetBSD 9.0sparc64py310-reprotest-0.7.22.tgz
NetBSD 9.0sparc64py311-reprotest-0.7.22.tgz
NetBSD 9.0sparc64py38-reprotest-0.7.22.tgz
NetBSD 9.0sparc64py39-reprotest-0.7.22.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.