Daemon Power

The NetBSD Packages Collection: security/polkit

Brief description of the package:
Authorization Manager

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.freedesktop.org/wiki/Software/polkit.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "security/polkit" directory. The current source version of the package is "polkit-0.116nb3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for security/polkit :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: mozjs60>=60.8.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 libffi>=1.20 libffi>=3.3nb1 readline>=2.2 readline>=6.0 icu>=3.4 python27>=2.7.1nb2 icu>=67.1 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.8 mozjs60>=60.8.0nb6 glib2>=2.64.0nb1 libxslt-[0-9]* libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libgcrypt>=1.6.0 libxml2>=2.9.10nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 perl>=5.0 .

This package requires the following package(s) to run: mozjs60>=60.8.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.3nb1 icu>=3.4 python27>=2.7.1nb2 icu>=67.1 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 mozjs60>=60.8.0nb6 glib2>=2.64.0nb1 .

This package supports the following build-time options:

introspection
Enable GObject Introspection support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:polkit-0.116nb3.tgz(NetBSD 9.0)
aarch64:polkit-0.115nb3.tgz(NetBSD 9.0)
aarch64:polkit-0.115nb4.tgz(NetBSD 9.0)
alpha:polkit-0.115nb3.tgz(NetBSD 8.0)
alpha:polkit-0.115nb3.tgz(NetBSD 9.0)
earmv6hf:polkit-0.115nb3.tgz(NetBSD 8.0)
earmv7hf:polkit-0.115nb4.tgz(NetBSD 8.0)
earmv7hf:polkit-0.115nb3.tgz(NetBSD 8.0)
earmv7hf:polkit-0.116nb3.tgz(NetBSD 8.0)
earmv7hf:polkit-0.115nb4.tgz(NetBSD 9.0)
earmv7hf:polkit-0.115nb3.tgz(NetBSD 9.0)
earmv7hf:polkit-0.116nb3.tgz(NetBSD 9.0)
i386:polkit-0.115nb4.tgz(NetBSD 9.0)
i386:polkit-0.115nb3.tgz(NetBSD 7.0)
i386:polkit-0.115nb3.tgz(NetBSD 7.0)
i386:polkit-0.115nb3.tgz(NetBSD 7.1)
i386:polkit-0.115nb3.tgz(NetBSD 7.1)
i386:polkit-0.115nb4.tgz(NetBSD 7.1)
i386:polkit-0.115nb3.tgz(NetBSD 8.0)
i386:polkit-0.115nb3.tgz(NetBSD 8.0)
i386:polkit-0.115nb4.tgz(NetBSD 8.0)
i386:polkit-0.115nb4.tgz(NetBSD 9.0)
i386:polkit-0.115nb3.tgz(NetBSD 9.0)
sparc64:polkit-0.114nb1.tgz(NetBSD 7.1)
sparc64:polkit-0.115nb3.tgz(NetBSD 8.0)
sparc64:polkit-0.115nb3.tgz(NetBSD 9.0)
x86_64:polkit-0.116nb2.tgz(NetBSD 9.0)
x86_64:polkit-0.116nb2.tgz(NetBSD 9.0)
x86_64:polkit-0.115nb3.tgz(NetBSD 7.0)
x86_64:polkit-0.115nb3.tgz(NetBSD 7.0)
x86_64:polkit-0.115nb3.tgz(NetBSD 7.1)
x86_64:polkit-0.115nb3.tgz(NetBSD 7.1)
x86_64:polkit-0.115nb4.tgz(NetBSD 7.1)
x86_64:polkit-0.115nb4.tgz(NetBSD 8.0)
x86_64:polkit-0.115nb3.tgz(NetBSD 8.0)
x86_64:polkit-0.115nb3.tgz(NetBSD 8.0)
x86_64:polkit-0.115nb4.tgz(NetBSD 9.0)
x86_64:polkit-0.115nb3.tgz(NetBSD 9.0)
x86_64:polkit-0.116nb2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]