net/lagrange - The NetBSD Packages Collection

Desktop GUI client for browsing Gemini

Lagrange is a desktop GUI client for browsing Geminispace. It offers modern
conveniences familiar from web browsers, such as smooth scrolling, inline
image viewing, multiple tabs, visual themes, Unicode fonts, bookmarks,
history, and page outlines.

Like Gemini, Lagrange has been designed with minimalism in mind. It depends
on a small number of essential libraries. It is written in C and uses SDL
for hardware-accelerated graphics. OpenSSL is used for secure communications.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto x11/xcb-proto devel/glib2-tools pkgtools/mktools devel/cmake devel/pkgconf pkgtools/cwrappers

Runtime dependencies

archivers/zip audio/mpg123 converters/fribidi devel/SDL2 devel/pcre fonts/harfbuzz graphics/hicolor-icon-theme textproc/libunistring devel/SDL2 devel/pcre fonts/harfbuzz graphics/hicolor-icon-theme textproc/libunistring

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64lagrange-1.17.4.tgz
NetBSD 10.0aarch64lagrange-1.17.4nb1.tgz
NetBSD 10.0aarch64eblagrange-1.17.4nb1.tgz
NetBSD 10.0earmv6hflagrange-1.17.4.tgz
NetBSD 10.0earmv6hflagrange-1.17.4nb2.tgz
NetBSD 10.0earmv7hflagrange-1.17.4nb2.tgz
NetBSD 10.0earmv7hflagrange-1.17.4.tgz
NetBSD 10.0i386lagrange-1.17.4nb2.tgz
NetBSD 10.0i386lagrange-1.17.4.tgz
NetBSD 10.0i386lagrange-1.17.4nb1.tgz
NetBSD 10.0powerpclagrange-1.15.8nb1.tgz
NetBSD 10.0powerpclagrange-1.17.4.tgz
NetBSD 10.0sparc64lagrange-1.17.4nb1.tgz
NetBSD 10.0x86_64lagrange-1.17.4nb2.tgz
NetBSD 10.0x86_64lagrange-1.17.4.tgz
NetBSD 10.0x86_64lagrange-1.17.4nb1.tgz
NetBSD 9.0aarch64lagrange-1.17.4nb2.tgz
NetBSD 9.0aarch64lagrange-1.17.4.tgz
NetBSD 9.0aarch64lagrange-1.17.4nb1.tgz
NetBSD 9.0earmv6hflagrange-1.17.4nb2.tgz
NetBSD 9.0earmv6hflagrange-1.17.4.tgz
NetBSD 9.0earmv7hflagrange-1.17.4nb2.tgz
NetBSD 9.0earmv7hflagrange-1.17.4.tgz
NetBSD 9.0i386lagrange-1.17.4nb2.tgz
NetBSD 9.0i386lagrange-1.17.4.tgz
NetBSD 9.0i386lagrange-1.17.4nb1.tgz
NetBSD 9.0powerpclagrange-1.17.4.tgz
NetBSD 9.0powerpclagrange-1.15.8nb1.tgz
NetBSD 9.0powerpclagrange-1.17.4nb1.tgz
NetBSD 9.0x86_64lagrange-1.17.4nb2.tgz
NetBSD 9.0x86_64lagrange-1.17.4.tgz
NetBSD 9.0x86_64lagrange-1.17.4nb1.tgz
NetBSD 9.3x86_64lagrange-1.17.4nb2.tgz
NetBSD 9.3x86_64lagrange-1.17.4nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

mpg123
Enable MP3 support using mpg123.
opengl
Use OpenGL as display library.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.