math/scilab - The NetBSD Packages Collection

High-level scientific math programming environment with graphics

Scilab is a scientific software package for numerical computations including:
 * Elaborate data structures (polynomial, rational and string matrices, lists,
   multivariable linear systems,...).
 * Sophisticated interpreter and programming language with Matlab-like syntax.
 * Hundreds of built-in math functions (new primitives can easily be added).
 * Stunning graphics (2d, 3d, animation).
 * Open structure (easy interfacing with Fortran and C via online dynamic
   link).
 * Many built-in libraries:
    + Linear Algebra (including sparse matrices, Kronecker form,
      ordered Schur,...).
    + Control (Classical, LQG, H-infinity,...).
    + Package for LMI (Linear Matrix Inequalities) optimization.
    + Signal processing.
    + Simulation (various ode's, dassl,...).
    + Optimization (differentiable and non-differentiable, LQ solver).
    + Scicos, an interactive environment for modeling and simulation of
      hybrid systems.
    + Metanet (network analysis and optimization).
 * Symbolic capabilities through Maple interface.
 * Parallel Scilab.
For more information about Scilab, send an e-mail to Doctor Scilab:
Scilab@inria.fr

Build dependencies

devel/libtool-fortran pkgtools/x11-links textproc/sablotron x11/xorgproto pkgtools/cwrappers textproc/sablotron devel/libtool-base

Runtime dependencies

lang/gcc7 parallel/pvm3 x11/tk x11/libXaw3d lang/gcc7 parallel/pvm3 x11/tk

Binary packages

OSArchitectureVersion
(none)

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.