math/ocaml-zarith - The NetBSD Packages Collection

OCaml arithmetic library for arbitrary precision integers

The Zarith library implements arithmetic and logical operations over
arbitrary precision numbers.  It uses GMP to efficiently implement
arithmetic over large numbers.  Small integers are represented as Caml
unboxed integers for speed and space economy.

Build dependencies

pkgtools/cwrappers devel/gmake lang/perl5

Runtime dependencies

devel/gmp devel/ocaml-findlib lang/ocaml devel/gmp devel/ocaml-findlib

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-zarith-1.7nb2.tgz
NetBSD 8.0i386ocaml-zarith-1.7nb2.tgz
NetBSD 8.0i386ocaml-zarith-1.7nb3.tgz
NetBSD 8.0powerpcocaml-zarith-1.7nb2.tgz
NetBSD 8.0powerpcocaml-zarith-1.7nb2.tgz
NetBSD 8.0x86_64ocaml-zarith-1.7nb2.tgz
NetBSD 8.0x86_64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0aarch64ocaml-zarith-1.7nb3.tgz
NetBSD 9.0aarch64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0aarch64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0earmv6hfocaml-zarith-1.7nb3.tgz
NetBSD 9.0earmv6hfocaml-zarith-1.7nb2.tgz
NetBSD 9.0earmv6hfocaml-zarith-1.7nb2.tgz
NetBSD 9.0earmv7hfocaml-zarith-1.7nb3.tgz
NetBSD 9.0earmv7hfocaml-zarith-1.7nb2.tgz
NetBSD 9.0earmv7hfocaml-zarith-1.7nb2.tgz
NetBSD 9.0i386ocaml-zarith-1.7nb2.tgz
NetBSD 9.0i386ocaml-zarith-1.7nb2.tgz
NetBSD 9.0powerpcocaml-zarith-1.7nb2.tgz
NetBSD 9.0x86_64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0x86_64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0x86_64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0x86_64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0x86_64ocaml-zarith-1.7nb2.tgz
NetBSD 9.0x86_64ocaml-zarith-1.7nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.