lang/lush - The NetBSD Packages Collection

Lisp interpreter/compiler with a seamless interface to C

Lush is an object-oriented Lisp interpreter/compiler with features
designed to please people who want to prototype large numerical
applications. Lush includes an extensive library of
vector/matrix/tensor manipulation, numerous numerical libraries
(including GSL, LAPACK, and BLAS), a set of graphic functions, a
simple GUI toolkit, and interfaces to various graphic and multimedia
libraries such as OpenGL, SDL, Video4Linux, and ALSA (video/audio
grabbing), and others. Lush is an ideal frontend script language for
programming projects written in C or other languages.  Lush also has
libraries for Machine Learning, Neural Nets and statistical estimation
(which are the main interests of the authors).

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto devel/libtool-base pkgtools/mktools devel/gmake pkgtools/cwrappers

Runtime dependencies

math/gsl math/lapack devel/SDL graphics/MesaLib devel/readline audio/libaudiofile math/gsl math/lapack devel/SDL graphics/MesaLib devel/readline audio/libaudiofile

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64lush-1.2.1nb5.tgz
NetBSD 10.0aarch64lush-1.2.1nb5.tgz
NetBSD 10.0earmv7hflush-1.2.1nb5.tgz
NetBSD 10.0earmv7hflush-1.2.1nb5.tgz
NetBSD 10.0i386lush-1.2.1nb5.tgz
NetBSD 10.0powerpclush-1.2.1nb5.tgz
NetBSD 10.0powerpclush-1.2.1nb5.tgz
NetBSD 10.0x86_64lush-1.2.1nb5.tgz
NetBSD 10.0x86_64lush-1.2.1nb5.tgz
NetBSD 8.0i386lush-1.2.1nb5.tgz
NetBSD 8.0i386lush-1.2.1nb5.tgz
NetBSD 8.0powerpclush-1.2.1nb5.tgz
NetBSD 8.0powerpclush-1.2.1nb5.tgz
NetBSD 8.0powerpclush-1.2.1nb5.tgz
NetBSD 8.0x86_64lush-1.2.1nb5.tgz
NetBSD 8.0x86_64lush-1.2.1nb5.tgz
NetBSD 9.0aarch64lush-1.2.1nb5.tgz
NetBSD 9.0aarch64lush-1.2.1nb5.tgz
NetBSD 9.0aarch64lush-1.2.1nb5.tgz
NetBSD 9.0alphalush-1.2.1nb5.tgz
NetBSD 9.0alphalush-1.2.1nb5.tgz
NetBSD 9.0alphalush-1.2.1nb5.tgz
NetBSD 9.0alphalush-1.2.1nb5.tgz
NetBSD 9.0alphalush-1.2.1nb5.tgz
NetBSD 9.0earmv7hflush-1.2.1nb5.tgz
NetBSD 9.0earmv7hflush-1.2.1nb5.tgz
NetBSD 9.0earmv7hflush-1.2.1nb5.tgz
NetBSD 9.0i386lush-1.2.1nb5.tgz
NetBSD 9.0i386lush-1.2.1nb5.tgz
NetBSD 9.0i386lush-1.2.1nb5.tgz
NetBSD 9.0powerpclush-1.2.1nb5.tgz
NetBSD 9.0powerpclush-1.2.1nb5.tgz
NetBSD 9.0powerpclush-1.2.1nb5.tgz
NetBSD 9.0sparc64lush-1.2.1nb5.tgz
NetBSD 9.0sparc64lush-1.2.1nb5.tgz
NetBSD 9.0sparc64lush-1.2.1nb5.tgz
NetBSD 9.0sparc64lush-1.2.1nb5.tgz
NetBSD 9.0sparc64lush-1.2.1nb5.tgz
NetBSD 9.0x86_64lush-1.2.1nb5.tgz
NetBSD 9.0x86_64lush-1.2.1nb5.tgz
NetBSD 9.0x86_64lush-1.2.1nb5.tgz
NetBSD 9.0x86_64lush-1.2.1nb5.tgz
NetBSD 9.0x86_64lush-1.2.1nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.