Daemon Power

The NetBSD Packages Collection: graphics/graphviz

Brief description of the package:
Graph Drawing Programs from AT&T Research and Lucent Bell Labs

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.graphviz.org/.

Please note that this package has a epl-v1.0 license.

The package is located in the "graphics/graphviz" directory. The current source version of the package is "graphviz-2.38.0nb3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for graphics/graphviz :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 x11-links>=0.91 osabi-NetBSD-6.1_STABLE renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.2 Xrender>=0.8.2 fontconfig>=2.10.93nb2 Xrender>=0.9.0nb1 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.32.1 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 harfbuzz>=0.9.9 icu>=3.4 icu>=54.1nb1 glib2>=2.34.0 harfbuzz>=0.9.4 cairo>=1.12.10 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 xproto>=7.0.9 Xfixes>=2.0.1nb2 damageproto>=1.1.0 libdrm>=2.4.24 libdrm>=2.4.15 glproto>=1.4.11 glproto>=1.4.6 python27>=2.7 readline>=2.2 readline>=6.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 dri2proto>=2.1 dri2proto>=2.0 xf86driproto>=2.0.4 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 python27>=2.7.1nb2 libxml2>=2.8.0nb2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.11 xcb-proto>=1.4 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 glib2>=2.14.0 cairo>=1.12.16nb2 Xft2>=2.1.7nb6 harfbuzz>=0.9.17nb2 cairo-gobject>=1.12.16nb1 help2man-[0-9]* p5-gettext>=1.01 perl>=5.20.0 perl<5.22.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.36.0 libffi>=3.0.0 gobject-introspection>=1.34.0 gtk2+>=2.4.0 py27-expat-[0-9]* shared-mime-info>=0.15 atk>=1.30.0 glib2>=2.31.2 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 tiff>=4.0.3nb5 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1.2nb2 libXi>=1.3.0 inputproto>=2.3 xextproto>=7.0.3 xproto>=7.0.13 libXi>=1.0.0 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 libXcomposite>=0.3.1 compositeproto>=0.4 compositeproto>=0.3.1 pango>=1.20.0 cairo>=1.6.0 shared-mime-info>=1.0nb1 atk>=2.6.0 gdk-pixbuf2>=2.26.5nb2 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.36.3nb1 gobject-introspection>=0.9.3 gd>=2.0.15nb1 libvpx>=0.9.2 yasm-[0-9]* libvpx>=1.0.0 lua52>=5.2.0<5.3 tk>=8.5.7 tcl>=8.5.7 tcl>=8.6.1nb1 libltdl>=2.4.2 gtk2+>=2.24.22nb3 gd>=2.1.0 tk>=8.6.1 libltdl>=2.2.6 swig>=1.3.24<2.0 swig>=1.3.31<2.0 .

This package requires the following package(s) to run: pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 Xrender>=0.2 Xrender>=0.8.2 fontconfig>=2.10.93nb2 Xrender>=0.9.0nb1 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.32.1 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 harfbuzz>=0.9.9 icu>=3.4 icu>=54.1nb1 glib2>=2.34.0 harfbuzz>=0.9.4 cairo>=1.12.10 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libdrm>=2.4.24 libdrm>=2.4.15 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 glib2>=2.14.0 cairo>=1.12.16nb2 Xft2>=2.1.7nb6 harfbuzz>=0.9.17nb2 cairo-gobject>=1.12.16nb1 gtk2+>=2.4.0 py27-expat-[0-9]* python27>=2.7 python27>=2.7.1nb2 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 atk>=1.30.0 glib2>=2.31.2 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 tiff>=4.0.3nb5 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1.2nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 cairo>=1.6.0 shared-mime-info>=1.0nb1 atk>=2.6.0 gdk-pixbuf2>=2.26.5nb2 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.36.3nb1 gd>=2.0.15nb1 libvpx>=0.9.2 libvpx>=1.0.0 lua52>=5.2.0<5.3 tk>=8.5.7 tcl>=8.5.7 tcl>=8.6.1nb1 perl>=5.20.0 perl<5.22.0 libltdl>=2.4.2 gtk2+>=2.24.22nb3 gd>=2.1.0 tk>=8.6.1 libltdl>=2.2.6 .

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:graphviz-2.24.0nb4.tgz(NetBSD 5.1)
arm:graphviz-2.26.3nb18.tgz(NetBSD 6.0)
arm:graphviz-2.34.0nb7.tgz(NetBSD 6.1_STABLE)
i386:graphviz-2.26.3nb15.tgz(NetBSD 4.0.1)
i386:graphviz-2.38.0nb1.tgz(NetBSD 5.1)
i386:graphviz-2.34.0nb7.tgz(NetBSD 5.1)
i386:graphviz-2.26.3nb23.tgz(NetBSD 5.1.2)
i386:graphviz-2.38.0nb3.tgz(NetBSD 5.2)
i386:graphviz-2.38.0nb3.tgz(NetBSD 6.0)
i386:graphviz-2.26.3nb27.tgz(NetBSD 6.0)
i386:graphviz-2.34.0.tgz(NetBSD 6.0)
i386:graphviz-2.34.0nb5.tgz(NetBSD 6.0)
i386:graphviz-2.34.0nb7.tgz(NetBSD 6.0)
i386:graphviz-2.38.0nb1.tgz(NetBSD 6.0)
i386:graphviz-2.24.0nb3.tgz(SunOS 5.10)
powerpc:graphviz-2.26.3nb11.tgz(NetBSD 5.1)
powerpc:graphviz-2.26.3nb9.tgz(NetBSD 5.1)
powerpc:graphviz-2.26.3nb18.tgz(NetBSD 5.2)
powerpc:graphviz-2.26.3nb9.tgz(NetBSD 6.0_BETA2)
powerpc:graphviz-2.26.3nb15.tgz(NetBSD 6.0)
sparc64:graphviz-2.34.0nb7.tgz(NetBSD 6.1_STABLE)
x86_64:graphviz-2.38.0nb1.tgz(NetBSD 5.1)
x86_64:graphviz-2.26.3nb22.tgz(NetBSD 5.1)
x86_64:graphviz-2.34.0nb7.tgz(NetBSD 5.1)
x86_64:graphviz-2.38.0nb3.tgz(NetBSD 5.2)
x86_64:graphviz-2.26.3nb22.tgz(NetBSD 6.0)
x86_64:graphviz-2.26.3nb27.tgz(NetBSD 6.0)
x86_64:graphviz-2.34.0.tgz(NetBSD 6.0)
x86_64:graphviz-2.34.0nb5.tgz(NetBSD 6.0)
x86_64:graphviz-2.34.0nb7.tgz(NetBSD 6.0)
x86_64:graphviz-2.38.0nb1.tgz(NetBSD 6.0)
x86_64:graphviz-2.38.0nb3.tgz(NetBSD 6.0)
x86_64:graphviz-2.38.0nb1.tgz(NetBSD 7.0_BETA)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]