emulators/mgba - The NetBSD Packages Collection

Emulator for running Game Boy Advance games (CLI version)

mGBA is an emulator for running Game Boy Advance games. It aims to
be faster and more accurate than many existing Game Boy Advance
emulators, as well as adding features that other emulators lack.

It also supports Game Boy and Game Boy Color games.

This package contains the command line version.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/mktools devel/cmake devel/pkgconf pkgtools/cwrappers

Runtime dependencies

devel/libelf graphics/MesaLib graphics/glu graphics/glu graphics/libepoxy archivers/libzip devel/SDL2 graphics/hicolor-icon-theme graphics/png graphics/MesaLib graphics/glu archivers/libzip devel/SDL2 graphics/hicolor-icon-theme graphics/png

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64mgba-0.9.3nb4.tgz
NetBSD 10.0aarch64mgba-0.10.0.tgz
NetBSD 10.0earmv6hfmgba-0.9.3nb4.tgz
NetBSD 10.0earmv6hfmgba-0.10.0.tgz
NetBSD 10.0earmv7hfmgba-0.9.3nb4.tgz
NetBSD 10.0earmv7hfmgba-0.10.0.tgz
NetBSD 10.0x86_64mgba-0.10.0.tgz
NetBSD 10.0x86_64mgba-0.9.3nb4.tgz
NetBSD 8.0earmv7hfmgba-0.9.1nb1.tgz
NetBSD 8.0x86_64mgba-0.9.3nb4.tgz
NetBSD 9.0aarch64mgba-0.9.3nb4.tgz
NetBSD 9.0aarch64mgba-0.9.3nb2.tgz
NetBSD 9.0aarch64mgba-0.10.0.tgz
NetBSD 9.0earmv6hfmgba-0.9.3nb2.tgz
NetBSD 9.0earmv6hfmgba-0.9.3nb4.tgz
NetBSD 9.0earmv6hfmgba-0.10.0.tgz
NetBSD 9.0earmv7hfmgba-0.9.3nb4.tgz
NetBSD 9.0earmv7hfmgba-0.10.0.tgz
NetBSD 9.0earmv7hfmgba-0.9.3nb2.tgz
NetBSD 9.0mips64ebmgba-0.9.3.tgz
NetBSD 9.0sparc64mgba-0.9.3.tgz
NetBSD 9.0sparc64mgba-0.9.3nb2.tgz
NetBSD 9.0sparc64mgba-0.9.3nb4.tgz
NetBSD 9.0x86_64mgba-0.9.3nb2.tgz
NetBSD 9.0x86_64mgba-0.9.3nb2.tgz
NetBSD 9.0x86_64mgba-0.9.3nb2.tgz
NetBSD 9.0x86_64mgba-0.9.3nb4.tgz
NetBSD 9.0x86_64mgba-0.9.3nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

opengl
Use OpenGL as display library.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.