devel/libextractor - The NetBSD Packages Collection

Metadata extractor for various file data types

libextractor is a simple library for keyword extraction.  libextractor
does not support all formats but supports a simple plugging mechanism
such that you can quickly add extractors for additional formats, even
without recompiling libextractor. libextractor typically ships with a
dozen helper-libraries that can be used to obtain keywords from common
file-types.

Build dependencies

pkgtools/x11-links lang/gcc10 lang/gcc10 devel/glib2-tools devel/libtool-base pkgtools/mktools devel/gmake devel/pkgconf pkgtools/cwrappers

Runtime dependencies

audio/flac audio/libsmf audio/libvorbis devel/libgsf graphics/tiff graphics/jpeg devel/libltdl graphics/ImageMagick graphics/exiv2 graphics/giflib multimedia/ffmpeg4 multimedia/libmpeg2 multimedia/mp4v2 www/tidy lang/gcc10-libs audio/flac audio/libvorbis devel/libgsf graphics/tiff graphics/jpeg devel/libltdl graphics/ImageMagick graphics/exiv2 graphics/giflib multimedia/ffmpeg4 multimedia/libmpeg2

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64libextractor-1.11nb12.tgz
NetBSD 10.0aarch64libextractor-1.11nb13.tgz
NetBSD 10.0aarch64eblibextractor-1.11nb13.tgz
NetBSD 10.0earmv6hflibextractor-1.11nb12.tgz
NetBSD 10.0earmv7hflibextractor-1.11nb12.tgz
NetBSD 10.0x86_64libextractor-1.11nb18.tgz
NetBSD 9.0aarch64libextractor-1.11nb12.tgz
NetBSD 9.0alphalibextractor-1.11nb6.tgz
NetBSD 9.0earmv6hflibextractor-1.11nb12.tgz
NetBSD 9.0earmv7hflibextractor-1.11nb12.tgz
NetBSD 9.0mips64eblibextractor-1.11nb6.tgz
NetBSD 9.0powerpclibextractor-1.11nb6.tgz
NetBSD 9.0powerpclibextractor-1.11nb12.tgz
NetBSD 9.0sparc64libextractor-1.11nb6.tgz
NetBSD 9.0sparclibextractor-1.11nb6.tgz
NetBSD 9.0x86_64libextractor-1.11nb18.tgz
NetBSD 9.0x86_64libextractor-1.11nb13.tgz
NetBSD 9.3x86_64libextractor-1.11nb13.tgz
NetBSD 9.3x86_64libextractor-1.11nb18.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.