audio/libaudec - The NetBSD Packages Collection

Audio decoding library

libaudec (lib audio decoder) is a wrapper library over minimp3, sndfile and
libsamplerate for reading and resampling audio files, based on Robin Gareus'
audio_decoder code.

libaudec supports all formats supported by sndfile, in addition to MP3.

This library is meant to be linked in statically to larger projects.

Until version 1.0 is released, the API is subject to change.

libaudec is released under the GNU Affero GPLv3+.

Build dependencies

devel/meson devel/pkgconf pkgtools/cwrappers

Runtime dependencies

audio/libsamplerate audio/libsndfile audio/libsamplerate audio/libsndfile

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibaudec-0.3.4.tgz
NetBSD 8.0i386libaudec-0.3.4nb1.tgz
NetBSD 8.0i386libaudec-0.3.4nb1.tgz
NetBSD 8.0powerpclibaudec-0.3.4.tgz
NetBSD 8.0powerpclibaudec-0.3.4.tgz
NetBSD 8.0x86_64libaudec-0.3.4nb1.tgz
NetBSD 8.0x86_64libaudec-0.3.4nb1.tgz
NetBSD 9.0aarch64libaudec-0.3.4nb1.tgz
NetBSD 9.0aarch64libaudec-0.3.4nb1.tgz
NetBSD 9.0alphalibaudec-0.3.4.tgz
NetBSD 9.0earmlibaudec-0.3.4.tgz
NetBSD 9.0earmlibaudec-0.3.4nb1.tgz
NetBSD 9.0earmlibaudec-0.3.4nb1.tgz
NetBSD 9.0earmv6hflibaudec-0.3.4nb1.tgz
NetBSD 9.0earmv6hflibaudec-0.3.4nb1.tgz
NetBSD 9.0earmv7hflibaudec-0.3.4nb1.tgz
NetBSD 9.0earmv7hflibaudec-0.3.4nb1.tgz
NetBSD 9.0i386libaudec-0.3.4nb1.tgz
NetBSD 9.0i386libaudec-0.3.4nb1.tgz
NetBSD 9.0i386libaudec-0.3.4nb1.tgz
NetBSD 9.0mips64eblibaudec-0.3.4.tgz
NetBSD 9.0mips64eblibaudec-0.3.4nb1.tgz
NetBSD 9.0mips64eblibaudec-0.3.4nb1.tgz
NetBSD 9.0powerpclibaudec-0.3.4.tgz
NetBSD 9.0powerpclibaudec-0.3.4.tgz
NetBSD 9.0sparc64libaudec-0.3.4.tgz
NetBSD 9.0sparc64libaudec-0.3.4nb1.tgz
NetBSD 9.0sparc64libaudec-0.3.4nb1.tgz
NetBSD 9.0sparclibaudec-0.3.4.tgz
NetBSD 9.0sparclibaudec-0.3.4.tgz
NetBSD 9.0sparclibaudec-0.3.4nb1.tgz
NetBSD 9.0x86_64libaudec-0.3.4nb1.tgz
NetBSD 9.0x86_64libaudec-0.3.4nb1.tgz
NetBSD 9.0x86_64libaudec-0.3.4nb1.tgz
NetBSD 9.0x86_64libaudec-0.3.4nb1.tgz
NetBSD 9.0x86_64libaudec-0.3.4nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.