x11/wxGTK28-contrib - The NetBSD Packages Collection

Contrib libraries for wxWidgets GTK

3rd-party contributed software for the wxWidgets cross-platform
GUI library (see x11/wxGTK package description for details).

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

multimedia/gstreamer0.10 devel/glib2 multimedia/gst-plugins0.10-base devel/GConf graphics/MesaLib graphics/glu graphics/glu graphics/jpeg graphics/png graphics/tiff x11/gtk2 x11/wxGTK28 multimedia/gstreamer0.10 devel/glib2 multimedia/gst-plugins0.10-base devel/GConf graphics/MesaLib graphics/glu graphics/jpeg graphics/png graphics/tiff x11/gtk2 x11/wxGTK28

Binary packages

OSArchitectureVersion
NetBSD 8.0i386wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 8.0i386wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 8.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 8.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 8.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 8.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 8.0x86_64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 8.0x86_64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0aarch64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0aarch64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0aarch64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmv6hfwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmv6hfwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmv6hfwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmv7hfwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmv7hfwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0earmv7hfwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0i386wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0i386wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0i386wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0mips64ebwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0mips64ebwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0mips64ebwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0mips64ebwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0mips64ebwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0powerpcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sh3elwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sh3elwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparc64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparc64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparc64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0sparcwxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0x86_64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0x86_64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0x86_64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0x86_64wxGTK28-contrib-2.8.12nb17.tgz
NetBSD 9.0x86_64wxGTK28-contrib-2.8.12nb17.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gstreamer
Enable gstreamer support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.