x11/py-wxWidgets - The NetBSD Packages Collection

Python bindings for wxWidgets

wxPython is a set of Python bindings for the powerful wxWidgets
cross-platform GUI library.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/gmake devel/pkgconf

Runtime dependencies

graphics/MesaLib lang/python27 graphics/glu graphics/glu x11/wxGTK28 x11/wxGTK28-contrib graphics/MesaLib lang/python27 graphics/glu x11/wxGTK28 x11/wxGTK28-contrib

Binary packages

OSArchitectureVersion
NetBSD 8.0i386py27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 8.0i386py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb13.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb15.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb13.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb15.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb13.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb15.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 8.0powerpcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 8.0x86_64py27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 8.0x86_64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0aarch64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0aarch64py27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0aarch64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0earmpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0earmpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0earmpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0earmv6hfpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0earmv6hfpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0earmv6hfpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0earmv7hfpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0earmv7hfpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0earmv7hfpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0i386py27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0i386py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0mips64ebpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0mips64ebpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0mips64ebpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0mips64ebpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0mips64ebpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb13.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb15.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb13.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb15.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb13.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb15.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb13.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb15.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0powerpcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0sh3elpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0sh3elpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0sh3elpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0sh3elpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0sparc64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0sparc64py27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0sparc64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0sparcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0sparcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0sparcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0sparcpy27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0sparcpy27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0x86_64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0x86_64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0x86_64py27-wxWidgets-2.8.12.0nb17.tgz
NetBSD 9.0x86_64py27-wxWidgets-2.8.12.0nb18.tgz
NetBSD 9.0x86_64py27-wxWidgets-2.8.12.0nb18.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.