x11/mate-screensaver - The NetBSD Packages Collection

Screen saver and locker for the MATE desktop

mate-screensaver is a screen saver and locker that aims to have
simple, sane, secure defaults and be well integrated with the desktop.
It is designed to support:

        * the ability to lock down configuration settings
        * translation into many languages
        * user switching

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers textproc/py-libxml2 devel/glib2-tools devel/libtool-base devel/gmake textproc/itstool devel/gettext-tools devel/pkgconf

Runtime dependencies

security/pam-pwauth_suid sysutils/consolekit lang/python38 lang/python38 x11/gtk3 devel/glib2 sysutils/desktop-file-utils x11/mate-desktop x11/mate-menus x11/libmatekbd x11/libXScrnSaver sysutils/dbus-glib sysutils/libnotify x11/gtk3 devel/glib2 sysutils/desktop-file-utils x11/mate-menus x11/libmatekbd sysutils/dbus-glib sysutils/libnotify

Binary packages

OSArchitectureVersion
NetBSD 8.0i386mate-screensaver-1.24.0nb3.tgz
NetBSD 8.0x86_64mate-screensaver-1.24.0nb4.tgz
NetBSD 8.0x86_64mate-screensaver-1.24.0nb3.tgz
NetBSD 8.0x86_64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0aarch64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0aarch64mate-screensaver-1.24.0nb3.tgz
NetBSD 9.0aarch64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0earmv7hfmate-screensaver-1.24.0nb3.tgz
NetBSD 9.0i386mate-screensaver-1.24.0nb3.tgz
NetBSD 9.0i386mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0i386mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0sparc64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0sparc64mate-screensaver-1.24.0nb1.tgz
NetBSD 9.0sparc64mate-screensaver-1.24.0nb3.tgz
NetBSD 9.0x86_64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0x86_64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0x86_64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0x86_64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0x86_64mate-screensaver-1.24.0nb3.tgz
NetBSD 9.0x86_64mate-screensaver-1.24.0nb4.tgz
NetBSD 9.0x86_64mate-screensaver-1.24.0nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.