x11/alacritty - The NetBSD Packages Collection

Cross-platform, GPU-accelerated terminal emulator

Alacritty is a terminal emulator with a strong focus on simplicity and
performance. With such a strong focus on performance, included
features are carefully considered and you can always expect Alacritty
to be blazingly fast (on modern hardware). By making good choices for
defaults, Alacritty requires no additional setup. However, it does
allow configuration of many aspects of the terminal.

Build dependencies

devel/cmake textproc/py-expat lang/rust x11/xcb-proto x11/xorgproto pkgtools/cwrappers lang/python38 pkgtools/digest devel/gmake devel/pkgconf

Runtime dependencies

fonts/fontconfig fonts/fontconfig graphics/freetype2 graphics/freetype2 x11/libxcb fonts/fontconfig

Binary packages

OSArchitectureVersion
NetBSD 8.0x86_64alacritty-0.7.2.tgz
NetBSD 8.0x86_64alacritty-0.6.0.tgz
NetBSD 9.0aarch64alacritty-0.7.2.tgz
NetBSD 9.0aarch64alacritty-0.6.0.tgz
NetBSD 9.0earmv7hfalacritty-0.7.2.tgz
NetBSD 9.0earmv7hfalacritty-0.6.0.tgz
NetBSD 9.0i386alacritty-0.6.0.tgz
NetBSD 9.0i386alacritty-0.7.2.tgz
NetBSD 9.0powerpcalacritty-0.6.0.tgz
NetBSD 9.0sparc64alacritty-0.7.2.tgz
NetBSD 9.0x86_64alacritty-0.5.0.tgz
NetBSD 9.0x86_64alacritty-0.6.0.tgz
NetBSD 9.0x86_64alacritty-0.6.0.tgz
NetBSD 9.0x86_64alacritty-0.7.2.tgz
NetBSD 9.0x86_64alacritty-0.6.0.tgz
NetBSD 9.0x86_64alacritty-0.7.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.